New Lenovo Ideapad grayish Laptop Laggy As Soon As Started

matthiaswright29

Prominent
Jan 1, 2018
3
0
510
0
So i got this Lenovo Laptop Ideapad and it told me to sign in and stuff,so when i signed it i download google chrome from it's website. Then when i signed into my google account it was lagging! its perfectly new and no viruses,theres been soulutions to Uninstalling McAffe ,and it tells me to restart my pc cause i just uninstalled it and its asking me right now to restart now or later. Before i restart lf this does not work is there any other soulution? it;s a model 120S-14lAP.
 

hang-the-9

Titan
Moderator


Are you testing connections in the same area? Test it with a network cable not on wireless. How much RAM is in the system? You rebooted the system right? All updates finish running if you check the windows update status?
 

hang-the-9

Titan
Moderator
First thing, wait till the system is fully loaded, including any Windows updates it may be trying to do.

You did not say exactly what "laggy" is, if on the internet, it may be a slow connection you are on, if it is actually slow opening files on the laptop that is another issue.

The system is a low end one, looks like they are under $300 for most models. That means a slow CPU, less RAM than most other better laptops and a slower hard drive. All of that will equal a slower system you may be used to from using other computers that use faster parts.
 

severinsen70

Prominent
Oct 15, 2017
111
0
710
40
First thing I do when getting a new PC; either A. remove all the bloatware, or B. Install a fresh windows install which also removes all the bloatware companies throw into these laptops for us..

That'd be my first step. Also if it uses an HDD rather than an SSD load times will be longer.

As for McAfee I'm not a big fan, I hate all the constant pop ups plus I think you only get 1 month free. I just use Windows defender and an ad blocker and I never get viruses
 

matthiaswright29

Prominent
Jan 1, 2018
3
0
510
0
so I tried your comment Hang 9, waited and went back on, still buffering and shuttering...it's like google does not want me to go to any youtube video nor site. also, it's not my internet...as it is rated 5 and it work's fast and perfect on my phone...so I need a good answer.
 

hang-the-9

Titan
Moderator


Are you testing connections in the same area? Test it with a network cable not on wireless. How much RAM is in the system? You rebooted the system right? All updates finish running if you check the windows update status?
 
Thread starter Similar threads Forum Replies Date
G Laptop General Discussion 3
Motherleche Laptop General Discussion 1
R Laptop General Discussion 0
samora.sm.sam Laptop General Discussion 0
Erin2020 Laptop General Discussion 2
A Laptop General Discussion 1
FragaZ Laptop General Discussion 2
L Laptop General Discussion 0
B Laptop General Discussion 1
M Laptop General Discussion 0
M Laptop General Discussion 2
A Laptop General Discussion 10
mqb2766 Laptop General Discussion 1
non hacker Laptop General Discussion 0
WilliamCheong Laptop General Discussion 1
Ruhan GM Laptop General Discussion 1
mistermish2000 Laptop General Discussion 2
M Laptop General Discussion 2
G Laptop General Discussion 1
R Laptop General Discussion 2

ASK THE COMMUNITY