New motherboard, still no power. PLEASE HELP!

DubLD

Commendable
Nov 16, 2016
6
0
1,510
0
Hi guys,

I recently damaged the motherboard on my HP Envy 17-3200, while modifying the frame to fit the new Seagate 4tb 2.5".

I bought a new motherboard online and installed but there is still no sign of life, whatsoever. No charging light, no fan, nothing happens when I push the power button.

I have tested with a multimeter and it is getting power to the power button and other components all over the motherboard.

The laptop is a bit old but it is my pride and joy and is definitely too good to give up on. , (i7 3200gh, 16gb ram, 5 Tb hdd, 250gb ss).

Could it be a dud motherboard?

I don't know what else to try, PLEASE HELP!
 

DubLD

Commendable
Nov 16, 2016
6
0
1,510
0
Hi Saga Lout (ha), thanks for your reply.
It was on the opposite side of the board and was a cut to an internal circuit with a sharp blade I was using to pare back a section of the frame.
 

DubLD

Commendable
Nov 16, 2016
6
0
1,510
0
Hi Chopper518, thanks.
Yeah, both the new and old MOBO's are ddr3.
I tried pulling and reseating the ram. Nothing.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
I Laptop Tech Support 3
M Laptop Tech Support 1
N Laptop Tech Support 9
R Laptop Tech Support 4
K Laptop Tech Support 0
palas Laptop Tech Support 3
D Laptop Tech Support 0
M Laptop Tech Support 0
joyesmoke Laptop Tech Support 1
Layton99 Laptop Tech Support 4
ekiryl Laptop Tech Support 3
A Laptop Tech Support 0
R Laptop Tech Support 3
D Laptop Tech Support 2
S Laptop Tech Support 4
G Laptop Tech Support 3
D Laptop Tech Support 2
trollzhxtroll Laptop Tech Support 1
S Laptop Tech Support 3

ASK THE COMMUNITY

TRENDING THREADS