Solved! 'No Battery is Detected' Surface Pro 3

Jan 9, 2019
3
0
10
0
I just replaced the battery in my Surface Pro 3(old one was swelling). Everything works fine, but the battery icon shows an 'x' and says "No Battery is Detected" when I hover over it. However, if I click on that, the battery info shows 100%. I can also unplug the power cord and it runs. I haven't tested how long it will run off of the cord beyond about 10 mins, however(and it still says 100%, which makes me doubt).
I've tried updating the battery driver in Device Manager, also uninstall and updating the same. I've tried the hard reboot with and without the power cord plugged in. Nothing changes.
I pretty much always have it plugged in, so it's not really an issue, but I would like to know that I can depend on the battery meter when it's unplugged.
Any ideas on how to get the correct icon meter? Thanks in advance!

 
Jan 8, 2019
8
0
10
0
More than likely if its an unoffical battery, its not going to display the data correctly. Definitely try running it without the cord to test the time it takes to die.
 
Jan 9, 2019
3
0
10
0


Knock off from Amazon. I'll check the connections next time I open it up(to replace the screen, because OF COURSE I broke it when changing the battery)
 
Jan 9, 2019
3
0
10
0


Yeah, it's a knock off. I'll definitely test it, soon...maybe...with some fear... :p
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 2
T Laptop Tech Support 1
A Laptop Tech Support 1
P Laptop Tech Support 9
N Laptop Tech Support 1
A Laptop Tech Support 1
W Laptop Tech Support 2
S Laptop Tech Support 1
A Laptop Tech Support 2
L Laptop Tech Support 2
A Laptop Tech Support 2
S Laptop Tech Support 1
J Laptop Tech Support 3
C Laptop Tech Support 1
R Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 1
M Laptop Tech Support 4
R Laptop Tech Support 3
Q Laptop Tech Support 3

ASK THE COMMUNITY