NO SOUND! Realtek HD Audio Can't be Installed.


Aug 17, 2013
First of all, here's my system:

MoBo: Asus P8Z77-M PRO
OS: Windows 7 Professional (My current OS. I've been reinstalling/reformatting from Ultimate many times hoping it would get fixed from that.)
CPU: Intel i7 3770 3.5Ghz w/ Liquid Cooler (Corsair Brand forgot the model name).
Monitor: PHILIPS brand (forgot the model name) 1080p LED on HDMI connection to the GPU.
GPU: 1x Palit Geforce GTX 680 4GB Jetstream
RAM: Kingston 2x8GB 1600Mhz

The dreaded problem is I have no more sound. A while back, (about 4 months ago) on my first clean OS install on my newly bought system, everything worked perfectly fine, all was well, installing drivers were fine, installing Realtek HD Audio Manager showed up after rebooting/restarting, no problems. Now, about a month or two ago, I've had audio problems, sometimes after turning on the PC, I got no sounds anymore, in the notifications bar/icons the sound symbol didn't have the red X (that red X indicates there is no sound) but it only now detects the monitor. Realtek HD Audio Manager was missing from the notification area. I've already checked my Speakers (Creative brand forgot the model name), they were fine, still sounding. I tried fixing it but it wasn't a permanent one, I went to Control Panel>Device Manager>System Devices tab>High Definition Audio Controller, I saw a small yellow triangle with a "!" symbol so I thought it had a problem, sometimes I try "Scan for hardware changes" and also Disabling it and then Enabling it and it did fixed it. The Realtek HD Audio Manager also showed up in the notification area and also in the Hardware and Sound from Control Panel. But sometimes when I shutdown/restart the PC and then after I turn it back on, I get those problems again then I have to repeat those steps again to fix it temporarily.

Now, I got to the point that those temporary fixes I've been doing won't work anymore. Realtek HD Audio Manager just doesn't show up anymore, I've tried uninstalling/reinstalling the yellow-triangled "!" High Definition Audio Controller to no avail. When I check the Playback Devices, the Speakers are not there but my Monitor and those HDMI "thingies". After getting so tired of having no sound (It's very hard to play games without sound, you don't know if you're getting ganked or not! :pt1cable:), I decided to reformat the drive/reinstall the OS. After I finished installing the OS, I went ahead to install the drivers from the MoBo CDs with a couple of reboots after, everything went okay except only for the Realtek HD Audio Manager/Driver. After rebooting from installing them, I still get no sound! The Realtek HD Audio Driver is installed and listed in Control Panel>List of Programs/Uninstall a Program but still nothing and not showing, Realtek HD Audio Manager still not on notification area. When I turn off the PC and then on the next day I turn it on, the sounds will work, Realtek HD Audio Manager will show up in notification area and also on Control Panel>Hardware and Sound menu, everything will work fine again. If I restart/shutdown the computer, it goes back to having no sounds again. Sometimes, the Realtek folder seems to have been installed in the C:/Program Files (NOT x86) and when I try to run the executables in it, nothing happens, though rarely they work when combined with disabling/enabling the High Definition Audio Controller with the Yellow triangle "!". I've also even tried Running it as Administrator, still nothing. So that's why I've been reformatting drive/reinstalling the OS again and again, now I'm trying with a different version of Windows 7, still the same problem.

What should I do? I'm running out of options, I guess I'll be sending this in to the store where I bought the components/computer parts from and let them check on it. Still on warranty though, so maybe that's good news?