Nvidia Control panel settings for GTX960m? (MSI GE62 2QD) (Performance Issues)

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0
Hello! I've been having some major performance issues recently with my laptop (Ever since I started using Nvidia GeForce Experience to "Optimize" my games) (I am now getting barely 60fps in cs:go no matter what in game settings I use, and very low fps in other games, even though I have nothing running in the background, I have the "Shift" mode on sport, my fans are at 100%, and I have high performance mode on in the Dragon Gaming Center, and I have it set to use "High Performance Nvidia Processor" ) I was wondering, what settings should I be using in the Nvidia Control panel (Global), and should I uninstall GeForce Experience?
Specs:
I7 5700HQ
GTX 960m (2gb)
8Gb RAM
 

JollyGreenGiant2

Commendable
Sep 10, 2016
20
0
1,570
2
Just wondering, have you tried to uninstall Nvidia Experience? and if so does it help? When you loaded it up it might have reverted everything back over to run off of the Intel chip set. In that case you would have to go to the Nividia control panel and switch it all back over.
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


No, I have not uninstalled GeForce Experience as of yet (I'll do that now), and it does randomly bring it back to intel chip set every now and then, but I always change it back :/
 

JollyGreenGiant2

Commendable
Sep 10, 2016
20
0
1,570
2


Okay Let me know if that works.
 

TechyInAZ

Admirable
Moderator
Make sure global settings for the GPU in Nvidia Control Panel are on auto-select. If you set EVERYTHING to the "High Performance NVIDIA Processor". You'll get weird bugs.

Just make sure the CSGO nvidia profile is set to "...Nvidia processor", and see what happens.
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


Nope, no good. I uninstalled GeForce Experience, changed my in game settings so V-sync is off (and changed it in the Control panel), turned sport mode and high performance mode on, made sure it was using the gpu, and fans on at 100%, still laggy and locked at 60fps (and other games are running much slower than usual). (Currently using the default settings in the Control panel, (which for some reason defaults to multi display performance mode, etc))
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


The issue still remains, the current settings I have it set up to (Defaults)
Global:
Auto Select
Ambient Occlusion - Off
Anisotropic filtering - App controlled
Antialiasing FXAA - Off
Antialiasing mode - App Controlled
Antialiasing transparency - Off
CUDA gpus - All
Max pre-rendered frames - Use the 3D app setting
Multi-display / mixed Gpu acceleration - multiple display performance mode (for some reason, I only use my laptop screen)
Power Management mode - Optimal Power
Shader Cache - On
Texture filtering Anisotropic Sample opti... - Off
Texture filtering - Negative LOD bias - Allow
Texture filtering - quality - Quality
Texture filtering - Trilinear - On
Threaded optimization - Auto
Triple buffering - Off
Vertical sync - Use 3D app setting
VR rendered frames - 1
 

TechyInAZ

Admirable
Moderator
Ok. Go ahead and completely uninstall then reinstall your nvidia graphics driver. BUT, REMEMBER to unplug your internet connection after downloading the geforce driver and restarting after uninstalling the old geforce driver. Or else windows will automatically reinstall the driver for you. Which we don't want since windows uses an older version of the geforce driver.

Also, make sure you check mark something about switching everything to defaults in the geforce installation wizard. You might of done something that messed up the profile in CSGO.
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


(Just double checking to make sure I don't screw anything up) So to do that, I download the new driver off Nvidias website (Save it to my desktop), go into windows control panel (add or remove programs) and remove all the old Nvidia drivers, put my laptop into airplane mode (I'm using wifi), restart, then proceed to install the new driver?
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


Oh and one more thing (Just while I'm waiting for it to finish downloading), do I need to boot it up in safe mode or anything? Else I think my laptop would automatically connect to the wifi no? (Ill try turning the wifi off as soon as it starts up)
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


Whoops, pressed custom installation, selected clean install (just in case) but forgot to uncheck GeForce experience, should I re do the whole process? Or just leave it as is?
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


Darn, after a complete re-install of the drivers, Im still having the issue (30-60fps in game or lower) :/ (All default settings, set to use Nvidia GPU in control panel, shift mode is on "Sport" , high preformance mode is on ( Dragon gaming center), fans on 100%)
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


Alright thanks! Ill give that a go (Also manually updating my motherboard BIOS, and other drivers, just to be safe).
 

kleanupsquad

Honorable
Feb 22, 2013
11
0
10,560
0


Alright, that gave my other games a slight boost to where they were about before, but CS:GO is still screwed (~30 fps when normally I get almost 200), Ill mark yours as the solution, thanks for the help!
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 1
I Laptop Tech Support 1
N Laptop Tech Support 4
C Laptop Tech Support 5
P Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 3
M Laptop Tech Support 3
H Laptop Tech Support 1
E Laptop Tech Support 4
D Laptop Tech Support 1
F Laptop Tech Support 8
S Laptop Tech Support 3
F Laptop Tech Support 5
W Laptop Tech Support 2
N Laptop Tech Support 2
D Laptop Tech Support 1
A Laptop Tech Support 2
G Laptop Tech Support 1
F Laptop Tech Support 2

Similar threads


ASK THE COMMUNITY

TRENDING THREADS