Old snow leopard up date needed

ewa.dalach

Prominent
Sep 10, 2017
1
0
510
0
I have old 10.6.8 snow leopard which I can't update from apple store for some reason. I need newer version to run skype. I am elderly person and desperately need help. I have screen shot of my comp configuration if needed. Thank you in advance.eva
 
Thread starter Similar threads Forum Replies Date
R MacBooks 1
S MacBooks 2
L MacBooks 1
8 MacBooks 1
D MacBooks 1
K MacBooks 1
S MacBooks 0
Z MacBooks 3
J MacBooks 6
G MacBooks 1
J MacBooks 1
A MacBooks 2
J MacBooks 4
P MacBooks 3
B MacBooks 2
L MacBooks 3
sparker781 MacBooks 1
V MacBooks 1
9 MacBooks 4
warezme MacBooks 6

ASK THE COMMUNITY