Only onboard card works, not the dedicated one

tonimoniaaaaa

Prominent
Jan 3, 2018
1
0
510
0
Hi Guys, have mx150 4gb ddr5 (lenovo ideapad 520 full hd), and onboard intel 620. I go to check on device manager it says Nvidia work properly, but when i open nvidia manage i see all outputs are on the intel 620 layer, not on geforce. I tried uninstall and install again all drivers from the official site, also i go to bios but i have only discreet option to choose not which card to use after i reboot. What to do? Only intel620 is used by my lap top while geforce works properly but its not used at all, plus problem hdmi i connect on my tv full hd (philips), and my lap top is also full hd, but on tv it shows bluured text nad graphic, i choose from tv options " PC" it clean lit bit but sitll blur. Thank you for ur advices
 
Laptop using other graphics card and not the Nvidia one?

First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
Laptop using other graphics card and not the Nvidia one?

First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 3
M Laptop Tech Support 3
A Laptop Tech Support 2
G Laptop Tech Support 3
J Laptop Tech Support 2
wicked_sticky Laptop Tech Support 5
E Laptop Tech Support 3
bailojustin Laptop Tech Support 1
N Laptop Tech Support 3
B Laptop Tech Support 2
F Laptop Tech Support 4
okieiam Laptop Tech Support 3
V Laptop Tech Support 2
S Laptop Tech Support 2
tranq07 Laptop Tech Support 2
J Laptop Tech Support 5
H Laptop Tech Support 1
J Laptop Tech Support 6
R Laptop Tech Support 1
G Laptop Tech Support 4

ASK THE COMMUNITY