Phone has started showing error "couldn't move app" when trying to move app to SD card.

Not open for further replies.


Apr 1, 2016
This is only a recent issue, I have been able to move my apps over well and fine before.
However, now whenever I try I get an error saying "couldn't move app". I have over 20 gb free storage.

I own an unlocked Smart Ultra 6. I have tried factory resetting the phone, formatting the SD card, replacing the SD card with a spare. Nothing has worked.

Is there anything I have missed that can fix this? I've searched everywhere for a solution.

EDIT: After a little experimentation, I've found that some of my apps do still move. But others don't. Which is which seems almost random, though I initially thought it was size I was able to move one of the bigger apps to my SD. This is honestly a very strange issue.

Not a strange issue, not...
Considering the version of Android your phone should be running (Lollipop), most apps should not be movable. Unless you have rooted the phone or have gotten it to upgrade to "Marshmallow".

To be able to move them, and run them, from the SD Card, you have to be able to set the card as "Internal" storage rather than "External". Which means that card would have to be blank to start with (to set it up) as it will format the card and then encode it when it is changed to "Internal".



Not a strange issue, not all apps can be moved from internal storage, it's pretty well known and is not an issue, it's how they were designed to work.
Not open for further replies.