Phone loses connection to home wifi every 2 or 3 days

agp10666

Prominent
Jan 19, 2018
4
0
510
0
Every 2 or 3 days my android phone loses connection to home wifi. Under wifi settings the network is indicated as "saved" - and continues to say this when I try to reconnect. I can reconnect to the network by rebooting the router - but it's a pain doing that every couple of days. Other phones in the house do not suffer this problem. Any ideas please?
 
Well, either there is a problem with the WiFi connection coming from the modem/router. If the modem/router is losing internet often, due to a bad device or bad signal from your ISP, that would cause the phone to lose connection but say it is in it. Some devices are very sensitive that way. So I would check your internet.

If that turns out to be OK, then there may well be a problem with something else on the phone. Either bad apps causing it, or other interference on the phone from something. Or it could also be the phone itself need to be reset. Lastly, the WiFi hardware in the phone has gone or is going bad. That would be the worst of it, as that would probably lead to a new phone being needed.
 
The loss may have nothing to do with the phone but with your ISP.

If the connection from the ISP 'blinks' out, you may not notice it at all on some devices, however other devices will react. This could be the issue with your phone. The only way to know is to monitor the modem/router and see when it/if it loses connection, has interference, etc.
 

agp10666

Prominent
Jan 19, 2018
4
0
510
0


Thanks webworkings - but why won't my phone reconnect to the wifi when I hit "connect" on the wifi settings? The wifi settings on the phone continues to display "saved". As I said I have to reboot the router in order to achieve connection.
 

agp10666

Prominent
Jan 19, 2018
4
0
510
0


I'm not sure what you mean by "clearing WIFI data". I've told it to "forget" the password and then re-keyed it. Is there something else to try which "clears WIFI data"?
 

agp10666

Prominent
Jan 19, 2018
4
0
510
0


Thanks - however - I've now tried this: I reconnected to WIFI after switching it back on, my connection lasted for a day and then disconnected, and now indicates "saved". When I try to reconnect now I just get the message "saved" - and no connection.
 
Well, either there is a problem with the WiFi connection coming from the modem/router. If the modem/router is losing internet often, due to a bad device or bad signal from your ISP, that would cause the phone to lose connection but say it is in it. Some devices are very sensitive that way. So I would check your internet.

If that turns out to be OK, then there may well be a problem with something else on the phone. Either bad apps causing it, or other interference on the phone from something. Or it could also be the phone itself need to be reset. Lastly, the WiFi hardware in the phone has gone or is going bad. That would be the worst of it, as that would probably lead to a new phone being needed.
 
Thread starter Similar threads Forum Replies Date
M Android Smartphones 0
harmionew Android Smartphones 0
C Android Smartphones 1
T Android Smartphones 1
Z Android Smartphones 0
M Android Smartphones 0
vijaylaxmipanol Android Smartphones 7
J Android Smartphones 2
Catalyst42 Android Smartphones 3
A Android Smartphones 1
C Android Smartphones 1
N Android Smartphones 1
D Android Smartphones 3
C Android Smartphones 2
P Android Smartphones 1
S Android Smartphones 5
M Android Smartphones 1
F Android Smartphones 2
C Android Smartphones 1
R Android Smartphones 5

ASK THE COMMUNITY