Question Polaroid TV Won’t Display Any Input Other Then DirecTV and Roku

Aug 18, 2019
2
0
10
0
Hi all! I have a weird problem I hope someone can help me with. I have an older 42 inch Polaroid TV.

Yesterday, for whatever reason, whenever I try to play a video on my Roku Ultra, it displays s purple screen. As I was trying to watch a live event, I hooked my laptop up, but the TV was not detected in either Windows or Linux. I next tried my desktop, which resulted in a black screen that said “1sp” on it. On the desktop, I tried every possible resolution. I next tried a blu ray player, and just like the laptops the tv said “No Signal”.

Any ideas what might be going on? I’ve hooked the laptops up to it before, and the desktop. I read that the purple screen might be HDCP, but it’s showing on all the major streams: Netflix, Prime, etc.

Thanks in advance!
 
Since you can't get anything to display on the TV the TV is broken. If you can get the internal tuner and menus up on the screen then the HDMI inputs may be bad. If the TV has a separate HDMI board you might be able to replace that. Otherwise may be time for a new TV.
 
Aug 18, 2019
2
0
10
0
I think you may be right. The crazy thing is that it works just fine with my satellite, and the Roku works until I try to play a stream. I can navigate the menus just fine.
 

ASK THE COMMUNITY