Problem with Logitech Gaming Software

Mar 10, 2014
2
0
4,510
0
I currently have a G400s Logitech Gaming Mouse which is in need of its driver, only which Logitech Gaming Software can fufill.

however,I tried downloading the Windows 8, 64 bit and 32 bit editions (I have Windows 8.1) driver to see if I could install it with no problems. Instead I have the massive problem of it just producing a 'processing' or sand timer and proceeds to kill the process of the setup off itself without warning or any indication.

This essentially means I can't install it but I am sure theres another way! Also I tried doing a clean boot and installing, attempted to use Windows 7 and even older ones... why exactly is not installing, or even opening for that matter?

Thank you in advance if a solution is found.
 

Pinhedd

Distinguished
Moderator


This is very odd. I have the Logitech Gaming Software installed on my Windows 8.1 64 bit PC without issue.

Make sure that there are no antivirus programs interfering with it.
 
Mar 10, 2014
2
0
4,510
0


I have my antivirus turned off but the installation will not initiate. I have also run administration privileges and compatibility mode. Now, this is definitely peculiar, surely its something to do with driver itself? The driver details are 8.53 (their latest), x64 build with Windows 8 as my selected OS. My computer has avast installed, has classic shell I recently JUST uninstalled Deathadder Razer Synapse, so that might boil it down a bit. Though a clean boot should easily install it instead it refuses.
 

rogerthat1946

Honorable
Dec 21, 2013
3
0
10,510
0

Thousands of people are having the same problems with Logitech software over the years.

A ton of people are having a similar problem even years later.
QUOTE me.

"Logitech Gaming Framework uses 328-Mb of memory and 13% of my Haswell i7 CPU use at all times."
Question is; is this really how much Memory and CPU use this software should use ??
This seems a lot of Haswell i7 CPU use that is not going to my programs ......
P.S.
Software version is 8.55

This page indicates something is wrong with my installed Logitech program....

http://www.shouldiremoveit.com/Logitech-Gaming-Sof​​tware-6032-program.aspx

Much much much much much much much much much smaller CPU use is supposed to occur.....

http://forums.logitech.com/t5/G-series-Gaming-Mice​/Logitech-Gaming-Framework-uses-328-Mb-memory-amp-​...
Unquote.

QED
Its an ongoing issue.
there is a bit of a fix by disabling some parts of Logitech software in the options.
 

rogerthat1946

Honorable
Dec 21, 2013
3
0
10,510
0


That fix works.
 
Thread starter Similar threads Forum Replies Date
F Apps General Discussion 5
J Apps General Discussion 0
P Apps General Discussion 4
I Apps General Discussion 2
kikani.kautik Apps General Discussion 2
synoptic12 Apps General Discussion 3
S Apps General Discussion 5
D Apps General Discussion 1
S Apps General Discussion 1
P Apps General Discussion 1
F Apps General Discussion 1
A Apps General Discussion 5
S Apps General Discussion 1
henrytcasey Apps General Discussion 2
P Apps General Discussion 1
A Apps General Discussion 1
S Apps General Discussion 1
V Apps General Discussion 1
O Apps General Discussion 2
U Apps General Discussion 1

ASK THE COMMUNITY