problem with my m18x laptop please please help


Dec 29, 2015
Hey there I've got a problem with my m18x laptop screen turning off when I plug the charger in I've been trying to fix a couple problems my self over the last few weeks and it's been a nightmare I've tried asking friends and searching hours and hours of forum posts , I'll list what I know so far and what I've done to try and fix the problem to make it easier.

Ok so I have purchased the pc in the last 2 months the previous owner had put windows 10 on the machine and it seemed to be working fine until I tried to play league of legends and I experienced a huge drop in fps from 244 fps on high settings down to 5-15 even on low about 5-10 seconds into the match, after trying to fix this problem with no results I ended up giving up and using the pc just for internet purposes.

About 2 weeks after that I got my first black screen when the charger was plugged in I hadn't changed any settings or installed anything , I 're booted several times and got the same problem as soon as I type my login details and press enter it would instantly go black (not dim as in low brightness like it's lost all power to the screen but the pc is still on),
I then tried to start the pc in safe mode and it worked no problem , I also discovered I can start the pc without the charger plugged in.

While I had the pc on without the charger I installed team viewer and was able to connect to and use the pc from a friend's computer after I plugged the charger in and the screen went black so the pc was deffinatly still on and working.

I next tried to change power plan settings and made sure the screen wasn't set to turn off when plugged in and also tried brightness settings nothing helped.

Next I ran a dxdiag and had no problems I also ran the diagnostics on the whole pc in the startup diagnostics and advanced scan again everything said it was working fine, I should also mention that the pc will not boot without the charger plugged in even with a fully charged battery and the battery is brand new so is the charger ,i have to plug it in press the power button then unplug the charger before the login screen, I have also tried to take battery out and boot just with charger in this works but still gets black screen after login.

After all this I wasn't sure what to do and my Google searches came up with nothing other than to turn the brightness setting all the way down because apparently windows 10 settings are reversed Wichita I did try but like I thought nothing happened so I decided to do a full wipe and start with a fresh windows 10 after another day trying to use the built in recovery to reset I kept getting errors saying I couldn't reset the pc.

After this point I decided to go back to windows 7 since the pc was made for 7 and I figured w10 was clashing with the pc so I installed a fresh copy of w7 home premium the same os that came with the pc and the problem was gone or so I thought I installed the drivers I could from the Dell m18x page got the net running then did a windows update, then installed service pack 1 and the nvidia experience program, I updated to the gaming ready driver through nvidias program and installed league of legends and tested out a match,
to my surprise it ran fine with no fps problems on high gfx and no black screen after that it was 3 am so I went to bed.

Next day I did another windows update installed Firefox, spybot search and destroy and a couple programs from piriform speccy, defraggler and ccleaner, after this I loaded up league and I played another match fine.

I should of been happy with this and left it alone but I remembered when I had tried the sli setting on w10 I was getting over 244 fps now I was only getting 140fps,
so here's where it went wrong Im not sure witch of the 3 things I did causes the problem but I had downloaded a single windows update earlier so I installed and restarted,
after that I swapped from balenced power settings to performance and I enabled sli mode.
After that I double clicked the league icon and as soon as I do the screen blacks out and since then the problem has been back and I have no idea what to try,

I took it back off sli mode with charger un plugged turned it back to balenced power settings uninstalled the windows update and all the programs I had downloaded and it's still not working.

the battery only lasts about an hour off charge so that's made it even harder through all of this please please someone help, I will post all the specs in the comments and am prepaired to try anything thank you in advanced.