Question Really in need of advice here...

Jul 12, 2020
1
0
10
0
Hey!

I want to start off by saying I'm new here. It is out of pure desperation that I made this account as I need help with a rather annoying problem (?). I do have a bit of anxiety problem so I'm sorry if I come across as ranty.

I'm new to gaming laptops! Probably a stupid move but about 16 days ago I bought the Razer Blade 15 1660 Ti. I'm a gamer first and foremost so I thought I'd join the dark side. I know next to nothing about gaming laptops but I like to think I'm tech minded. The setup was easy. No bloatware. I was content. Now there's one thing I don't know about laptops and that's batteries. So when I'm doing regular things like surfing the web and stuff, the battery stays at 100% charge plugged in (and I always have my laptop plugged in). I thought everything was going well until I started up a game. I noticed while gaming that the battery discharges to 95% then recharges to 100%. ALL. THE. DAMN. TIME. Like a cycle. 100% - 95% then back to 100% then discharges to 95% then back to 100%. I think in about an hour, It goes through one cycle and a bit. Now, I'm not dumb... I know that batteries have a limited cycle life so when I noticed this happening, I was caught off guard. My sister who owns an HP Omen doesn't do this. I honestly don't know if this is normal battery charging behaviour while gaming. I really needed to know if it is doing what it is meant to do.

I got onto Razer Live Chat about two weeks ago. Their response was generic and did not relate to my specific query at all. What's worse is that at the very beginning of the chat I was advised to take it back... Before I asked if it was normal. The guy told me to wait a few moments before checking and came back with this -

'the charge circuit does not always charge the battery to 100% in order to protect it and keep it in top condition. When the Razer Blade system has been run on battery only and you connect it to AC, it will charge the battery to 100% on the first charge. However, if the Razer Blade is left on AC, it will begin to cycle its charging and stop a little short of 100%. If you ever want to force it to charge to 100% again, just unplug it from AC, restart the notebook and reconnect it to AC. It will charge to 100% again. But, remember, if it is left connected to AC it will begin to cycle again in order to protect the battery.'

Why do I have a problem with this? Well... It doesn't really answer my question. The laptop discharges then recharges while gaming. No mention of that. Unless I'm misunderstanding?

Now I know this was copied and pasted. It was on their bloody website. I was obviously confused but knew I wasn't going to get anywhere.

So then I took it to Reddit... AND OH BOY. So I posted on their support sticky.... (I'm new to Reddit so... Meh) About SEVEN days later I got a reply to DM. So I DM'd them the support case number and a transcript of live chat with the gentleman 7 days prior. Keep in mind, every single message between us is taking a day to respond from their side... So I'm practically running out of time here in regards to sending it back to the retailer.

I got a reply from Razer. Do you wanna guess what it says?

'the charge circuit does not always charge the battery to 100% in order to protect it and keep it in top condition. When the Razer Blade system has been run on battery only and you connect it to AC, it will charge the battery to 100% on the first charge. However, if the Razer Blade is left on AC, it will begin to cycle its charging and stop a little short of 100%. If you ever want to force it to charge to 100% again, just unplug it from AC, restart the notebook and reconnect it to AC. It will charge to 100% again. But, remember, if it is left connected to AC it will begin to cycle again in order to protect the battery.'

Yup.

So at this point... I'm done. I could be making a huge problem out of nothing. I honestly don't know. I've reinstalled the ACPI and run a battery report. I'm not an expert but I don't see the 95% - 100% cycle on the report although major times are missing from it. I'm completely in the dark here and have had it with Customer Service.

I would really REALLY appreciate it if someone could let me know if this is normal behaviour for a battery while gaming...

I've checked online and keep getting different answers. I read something about Alienware having the 'feature' called Power Striking but then someone got a charger with different wattage and it stopped the behaviour altogether... And in the same post, Alienware said that wasn't true and that the charger shipped with the laptop is more than enough to power the laptop consistently?

I don't know guys. I'm just tired with it.

You would be saving my life and sanity if you could tell me if this is normal. I guess I'm just having a hard time believing that constant discharge and recharge while gaming isn't going to affect the overall life of the battery.

Thanks guys,

Storms
 
Last edited:
Thread starter Similar threads Forum Replies Date
N Laptop Tech Support 1
B Laptop Tech Support 1
A Laptop Tech Support 6
E Laptop Tech Support 1
A Laptop Tech Support 2
A Laptop Tech Support 1
T Laptop Tech Support 1
P Laptop Tech Support 4
Greyfalcon Laptop Tech Support 4
M Laptop Tech Support 3
J Laptop Tech Support 1
M Laptop Tech Support 1
I Laptop Tech Support 10
N Laptop Tech Support 3
T Laptop Tech Support 1
M Laptop Tech Support 1
P Laptop Tech Support 2
T Laptop Tech Support 3
C Laptop Tech Support 6
L Laptop Tech Support 1

ASK THE COMMUNITY