Solved! REALTEK - how to stop mono audio from being upscaled to stereo ?

Dec 22, 2018
3
0
10
1
Hi.

I have a Asus z370 motherboard with a Realtek HD Audio ALC1220. I have logitech speakers 5.1. The 5.1 speakers are all working. I get sounds from each speakers when I do tests in windows, and I get stereo and 5.1 audio perfectly. But when I play a movie with a mono soundtrack, the sound is always upscaled to stereo and comes from both left and right speakers, with no sound from the center speaker. I have found a workaround however but it's annoying having to do this each time. Once the movie has started, I switch the output using the speaker icon in the windows notification area from "speakers" to "digital output" which is not used so the sound cuts, then immediately back again to "speakers" and now the mono audio comes out of the center speaker as it should and both the left and right are silent. It remains like that as long as the movie plays. If I closed the player and restart the movie, the mono is back to upscaled stereo with no audio in the center speaker and I have to do the same workaround to make it output from the center speaker again. I have search the Internet extensively and haven't found any similar problem posted. Anyone would have any idea/suggestion?
PS: I installed today the latest UAD drivers for the realtek audio, version 6.0.1.8597. This didn't make any difference to my problem. As I said everything works correctly, i.e. stereo audio, 5.1 audio, the only problem is this upscaling from mono to stereo that I do not want...
Thanks in advance.
 
Dec 22, 2018
3
0
10
1
FIXED ! I finally found the solution. In the settings for ffdshow audio, I was not using the Mixer function. I didn't think I needed to because all my movies with soundtracks in either 2.0 or 5.1 were outputting correctly. However, in the Mixer options, there is the option to chose the Output Speakers Configuration, so I turned the Mixer on by checking its box and selected 3/2/1 - 6 channels as speakers configuration and now, the mono track is output on the center speaker. For the AC3 filter, the problem was that the Output format was set to "Do not change" which I assumed means the audio output is the same as the input. I thought this would have been the correct setting but I now changed it to 5.1 Surround and there again, it fixed the problem.
So in the end the problem was that I hadn't set the output correctly in the codecs.
 
Dec 22, 2018
3
0
10
1
I might have used the word "upscaled" incorrectly. I'm aware that it is the same mono track coming out of both the left and right speakers. I understand that it gives a larger soundstage with both left and right speakers than with the center one but I don't want this. When I'm watching old movies in mono, particularly Bergman's, I'd rather have the mono soundtrack only coming out of the center speaker which is positioned just under the tv screen. At first, I thought it was a software problem, I use the Shark007 codecs with Windows Media Player - I tried all permutations, using FFDshow, AC3Filter, different splitters, LAV, Haali, etc..., but the problem still remains, Same thing with MPC-HC (Media Player Classic)... Actually, I just tried with VLC player (which I didn't think of doing before now) and there's no problem! - the sound comes out of the center speaker as it should. I know VLC is self-contained and uses its own codecs so it's definitely something to do with software and Shark007, I'll have to go back to its settings and keep at it...
 
Dec 22, 2018
3
0
10
1
FIXED ! I finally found the solution. In the settings for ffdshow audio, I was not using the Mixer function. I didn't think I needed to because all my movies with soundtracks in either 2.0 or 5.1 were outputting correctly. However, in the Mixer options, there is the option to chose the Output Speakers Configuration, so I turned the Mixer on by checking its box and selected 3/2/1 - 6 channels as speakers configuration and now, the mono track is output on the center speaker. For the AC3 filter, the problem was that the Output format was set to "Do not change" which I assumed means the audio output is the same as the input. I thought this would have been the correct setting but I now changed it to 5.1 Surround and there again, it fixed the problem.
So in the end the problem was that I hadn't set the output correctly in the codecs.
 
Thread starter Similar threads Forum Replies Date
M Audio 0
jdip13 Audio 1
A Audio 6
I Audio 6
J Audio 1
K Audio 3
M Audio 10
K Audio 1
M Audio 3
S Audio 1
B Audio 1
S Audio 2
F Audio 3
M Audio 1
I Audio 2
W Audio 1
D Audio 3
M Audio 9
T Audio 1
J Audio 11

ASK THE COMMUNITY