Recording playback sounds tinny unless headset is plugged in during recording

Status
Not open for further replies.

ExpertNovice

Distinguished
Mar 25, 2006
12
0
18,560
0
Windows 10 Pro 64bit

I think this is the key to the solution but…. In sounds (system tray), tab playback, there are two options. When Speakers is the default recordings playback tinny. If Realtek Digital Output is the default the recording playback sounds good but, of course, I need to plug headsets in to get a good recording, so the speakers need to be the default.

Detail of the issue
The situation is simple. Listening to audio sounds good over the speakers or through a cheap headset. The difference is, when a jack (headset not required) is plugged into the headset plug the Realtek High Definition Audio dialog opens and asks what device was plugged in. Headphone is selected. Ok is clicked. Task manager shows the process “HD Audio Background Process” is loaded with or without the headset.

If a recording is made without the headset the playback sounds tinny. If the headset jack has a plug inserted before recording the recording sounds “perfect”. The sound heard during recording in both cases sounds good with or without a headset.


Any suggestions? Questions?

I have read many threads and forums, sound troubleshooting performed, looked for newer drivers, etc. I am concerned (<< chicken) about simply installing drivers for my ASUS ROG G751JY.

EN
 

mortemas

Estimable
Feb 11, 2015
57
0
4,610
15
OK, I need a clarification. When you say the playback of the recording sounds tinny, you mean the SAME recording sounds tinny whether you play it back using the laptop speakers OR your headphones? In other words, the tinniness is embedded in the file? By the way, what recording software are you using?

There's a possibility you have auto-sensing jacks and Windows is changing something when you put a plug into the jack.

Let's try this. Open the device list again (not the watered down Windows 10 sound settings, but the one found in Control Panel). On the Playback tab, highlight Speakers and click Properties. Click the Levels tab and set it to 50. Click the Enhancements tab and check the box that says Disable All Enhancements. Next, click the Advanced tab and select CD Quality (16 bit/44.1kHz). Click the Spatial Sound tab and select OFF. Click APPLY to make sure all the new settings take effect. Now, Click the Recording tab. Stereo Mix should be selected. Click Properties. Click the Listen tab and make sure "Listen to this device" is NOT checked (we might revisit this setting later). Click Levels tab and set to 50. Click Advanced tab and make sure it is CD quality (16 bit/44.1kHz) just like the Playback device. Click APPLY. We also need to check Realtek Sound Manager, too. We want to make sure there are no effects selected like Bass Boost, EQ, Karaoke Mode, Headphone Virtualization, Room Correction, etc. Now try the recording with your speakers as Output (without the headphones plugged in) and Stereo Mix as Input and see if it is still tinny. I'm reading that your laptop has this thing called SonicMaster/MaxxAudio. It could be a setting in there that is causing the problem, but I'm not familiar with that software. Did you say you already went to the Asus forums? You might find some help there, too.

EDIT: More thoughts...
Your laptop has a unique audio solution. There is a subwoofer, so I think SonicMaster/MaxxAudio is stripping out the low end bass and diverting it to the subwoofer, therefore by the time the signal gets to the stereo mix all the low frequencies are gone. The stereo mix sends the mids and highs to the left and right speakers. Does your subwoofer show up as a separate device in Device Manager or anywhere else? The reason why the recording sounds ok with headphones in is because the bass is not stripped out - the full range of frequencies should go to the headphone output jack so you hear the whole range of frequencies correctly in your headphones. Try this:

-Set Output to Realtek Digital Output
-Set Input to Stereo Mix
-Go to Recording tab and then Listen tab and check "Listen to this device" and select Speakers as the device to listen through

If you don't get a digital loop (might sound like buzzing or similar), then this might solve the problem. Not sure if you will only hear audio when you are recording, though. Hopefully it will come through during both playback and recording. I think the reason why you still get full range sound through Realtek Digital Output is that your digital optical output is intended to be connected to an external audio device (same reason as the headphones) and therefore the bass is not stripped out.
 

mortemas

Estimable
Feb 11, 2015
57
0
4,610
15
OK, honestly there's too much info there for me! Some questions. What are you recording? What is the recording device? Sounds like maybe you're hearing the difference between the laptop mic (more tinny) versus the headset mic (better quality mic). Is that it?
 

ExpertNovice

Distinguished
Mar 25, 2006
12
0
18,560
0
Thanks for responding!

Recording various websites from the internet.
The recording device is the computer. See below.
No. Here is a summary of the Detail.
The sound from the website sounds "perfect" over the speakers or headset.
Recordings made WITHOUT a headset plugged in sounds tinny when played back. With or without a headset.
Recordings made WITH a headset plugged in sounds "perfect" when played back. With or without a headset.


I never noticed this. Belarc says the Multimedia devices are:
NVIDIA High Definition Audio
NVIDIA Miracast Audio
NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
Realtek High Definition Audio

and Other audio devices are
Microphone (Realtek High Definition Audio)
Realtek Digital Output (Realtek High Definition Audio)
Speakers (Realtek High Definition Audio)
 

mortemas

Estimable
Feb 11, 2015
57
0
4,610
15
Ok, how about your headset? Do you mean that it is a headphone and mic combo? I think what you need to do next is observe which one of those devices is selected as the recording device, both with and without the headset plugged in. Also, try recording both ways and look to see which device meters are showing audio. This should allow you to identify which one is good and which one is making the recording sound tinny.

See here if you’re not super familiar with audio device selection and settings: https://www.howtogeek.com/271285/how-to-change-your-audio-playback-and-recording-devices-on-windows/
 

ExpertNovice

Distinguished
Mar 25, 2006
12
0
18,560
0
Thanks again. I don't seem to be able to explain that no headset is required.
What I want to be able to do is NOT use a headset, be able to hear the sound that is being recorded through the speakers while it is being recorded, and have the recorded sound not be tinny when played back.

Once a single 3.5 mm jack from this splitter is plugged into the computer's headset port then any sound recorded sounds good when played back. http://www.microcenter.com/product/473239/35mm-female-to-dual-1-4-ts-male-stereo-audio-splitter-adapter-6-in---black

The other male (microphone port) and female plug (headset jack) can remain unused. So, the computer "thinks" a headset is connected. Of course, no sound is heard during the recording because no sound eminates from the speakers and no headset is connected.

Thanks for the link. If Realtek Digital Output is selected the sound recorded sounds good when played back but no sound is heard over the speakers.
 

mortemas

Estimable
Feb 11, 2015
57
0
4,610
15
OK, sorry. I think we need to get terminology straight first. A headset is typically a combo of both earphones and a mic. You don't have a headset jack on your laptop. An xbox one controller or an iphone has a headset jack because it is a single jack that takes a single plug from a headset that has both earphones and a mic. You have separate headphone and mic jacks, so you don't have a headset jack. The splitter you linked to will not plug into anything on your laptop because it has 1/4" TS connectors and the laptop only has 1/8" jacks.

Forget about any headset this or that for now. It's a distraction. Don't plug anything into any jacks, make sure that Realtek High Definition Audio is selected as your output (or whatever has the icon of a speaker, not headphones) and follow this and tell me if it works:

https://www.youtube.com/watch?v=GqNrLfbwAH8

NOTES:
If you have Win10, the settings are in Control Panel > Hardware and Sound > Manage audio devices
The part about "Show Disabled Devices" is the key part here.

Lemme know how it goes.
 

ExpertNovice

Distinguished
Mar 25, 2006
12
0
18,560
0
Agreed, I wasn't sure what to call the port and the ASUS manual called it a jack port. Duh, the jack goes in the port. Sorry! And... thanks for your perseverance.

First: When I go through the "Speaker icon' in the system tray selecting "Open Sound Settings" there are two Output Devices available. "Speakers (Realtek High Definition Audio)" and "Realtek Digital Output (Realtek High Definition Audio)". The first is my default and produces tinny recordings unless a jack is plugged into the headset port. When the second is selected good recordings are produced but no sound is heard unless a headset is plugged into the headset port.

The two can be changed in the "Choose your output device" dropdown or by clicking "Sound Control Panel". The latter is the same panel on the Win10 Control Panel > Hardware and Sound > Manage audio devices selection.


Second, the link was about recording with a microphone but I followed the instructions and "Stereo Mix" was enabled in the Recording tab and made the default. I then recorded sound from a website and the recording was still tinny.

In the playback tab the item labeled "Speakers" is the default and recordings are tinny. If the Realtek Digital Output is selected recordings sound good. Of course, I can't hear what is being recorded or the recording playback without plugging in a headset or changing back to "Speakers".

arrrggghhhh :D

Thanks again.
 

mortemas

Estimable
Feb 11, 2015
57
0
4,610
15
OK, I need a clarification. When you say the playback of the recording sounds tinny, you mean the SAME recording sounds tinny whether you play it back using the laptop speakers OR your headphones? In other words, the tinniness is embedded in the file? By the way, what recording software are you using?

There's a possibility you have auto-sensing jacks and Windows is changing something when you put a plug into the jack.

Let's try this. Open the device list again (not the watered down Windows 10 sound settings, but the one found in Control Panel). On the Playback tab, highlight Speakers and click Properties. Click the Levels tab and set it to 50. Click the Enhancements tab and check the box that says Disable All Enhancements. Next, click the Advanced tab and select CD Quality (16 bit/44.1kHz). Click the Spatial Sound tab and select OFF. Click APPLY to make sure all the new settings take effect. Now, Click the Recording tab. Stereo Mix should be selected. Click Properties. Click the Listen tab and make sure "Listen to this device" is NOT checked (we might revisit this setting later). Click Levels tab and set to 50. Click Advanced tab and make sure it is CD quality (16 bit/44.1kHz) just like the Playback device. Click APPLY. We also need to check Realtek Sound Manager, too. We want to make sure there are no effects selected like Bass Boost, EQ, Karaoke Mode, Headphone Virtualization, Room Correction, etc. Now try the recording with your speakers as Output (without the headphones plugged in) and Stereo Mix as Input and see if it is still tinny. I'm reading that your laptop has this thing called SonicMaster/MaxxAudio. It could be a setting in there that is causing the problem, but I'm not familiar with that software. Did you say you already went to the Asus forums? You might find some help there, too.

EDIT: More thoughts...
Your laptop has a unique audio solution. There is a subwoofer, so I think SonicMaster/MaxxAudio is stripping out the low end bass and diverting it to the subwoofer, therefore by the time the signal gets to the stereo mix all the low frequencies are gone. The stereo mix sends the mids and highs to the left and right speakers. Does your subwoofer show up as a separate device in Device Manager or anywhere else? The reason why the recording sounds ok with headphones in is because the bass is not stripped out - the full range of frequencies should go to the headphone output jack so you hear the whole range of frequencies correctly in your headphones. Try this:

-Set Output to Realtek Digital Output
-Set Input to Stereo Mix
-Go to Recording tab and then Listen tab and check "Listen to this device" and select Speakers as the device to listen through

If you don't get a digital loop (might sound like buzzing or similar), then this might solve the problem. Not sure if you will only hear audio when you are recording, though. Hopefully it will come through during both playback and recording. I think the reason why you still get full range sound through Realtek Digital Output is that your digital optical output is intended to be connected to an external audio device (same reason as the headphones) and therefore the bass is not stripped out.
 

ExpertNovice

Distinguished
Mar 25, 2006
12
0
18,560
0
1.
a. plug a jack into the headset port
b. record
c. play back over speakers or headset and sound is good

2
a. remove anything from the headset port
b. record
c. play back over speakers or headset and sound is tinny


Camtasia Studio 8

Yes, windows is changing something when a jack is plugged into the port. From "Details of the Issue":
The difference is, when a jack (headset not required) is plugged into the headset plug the Realtek High Definition Audio dialog opens and asks what device was plugged in. Headphone is selected. Ok is clicked.

**** Click the Levels tab and set it to 50
Levels: Realtek HD Audio output was at 100 and changed to 50.
Internal Subwoofer, Center, Subwoofer, & Rear were left at 100.

**** Enhancements tab and check the box that says Disable All...
No such box exists. All sound effects were already unchecked. Immediate Mode was left checked, for now.

**** Advanced tab
24 bit, 48000 Hz was lowered to the lowest possible rate of 16 bit/44.1kHz.

**** Spatial sound
Off was already the setting.

**** Recording
Stereo Mix was left as the default. (It was enabled and made the default earlier today, with no change in quality)

**** Listen
Listen to this device was already disabled
**** Levels
Lowered to 50 from 55
**** Advanced
Weird. the default format is 2 channel, 16 bit, 48,000 Hz (DVD Quality)
But, the default format is grayed out so I can't lower it to CD Quality


RealTek:
Speakers:
Environment: was and is None
Equalizer: was and is None
Digital Output:
WHOA!
Environment: was Bathroom and is now None
Equalizer: was and is None

Testing:
Sound recorded without a jack in the headset port was even tinnier.
Sound recorded with a jack in the headset port sounded good.


Sonic Master: No
Looked in programs list, searched folders, control panel Programs, and even the registry. However, I found an Asus Audio Wizard with a setting of MultiMedia and this was changed to off. No change in recorded sound quality.

Finally, I went back and disabled "Immediate Mode". No change.

I will try in Asus forums as well. Thanks for the suggestion.
 

mortemas

Estimable
Feb 11, 2015
57
0
4,610
15
See in my edit of the above message about using the “Listen” feature, too. I think the specialized audio system with the subwoofer and how the system handles it is the problem.
 

ExpertNovice

Distinguished
Mar 25, 2006
12
0
18,560
0
Sorry, don't know how I missed your "More Thoughts" section!

Your suggestion about stripping out the low end bass makes perfect sense. I simply find no evidence that SonicMaster is installed, and the ROG Audio Wizard was, supposedly, turned off. Not sure about MaxxAudio. This gives me more vocabulary with which to search! Thanks!

Looking in "Audio Inputs and outputs", and "Sound, video and game controllers" I see nothing about a subwoofer.

-Set Output to Realtek Digital Output
Done in Playback tab of "Sound"

-Set Input to Stereo Mix
Done in Recording tab of "Sound"

-Go to Recording tab and then Listen tab
Found in properties of "Stereo Mix"

- and check "Listen to this device" & select Speakers as to listen through
Done

-If you don't get a digital loop (might sound like buzzing or similar), then this might solve the problem.
??? No sound was produced. In fact, no sound can be heard through speakers or headsets.

For once, I did not document the before and after settings. A little playing and sound is back. with same issues.

Your last statement also makes sense and fits nicely with the first. While I love this laptop this one problem has bugged me for years. The worst part is that I sometimes record, for example, a webinar and only later realize that I again forgot to plug in a headset. Other times, I simply don't want to wear one.

If you have any other suggestions I'm all ears, as long as a speaker isn't needed.... :D

Again, thank you so much for your help and perseverance.
 

ExpertNovice

Distinguished
Mar 25, 2006
12
0
18,560
0
After searching with the terminology you taught me the very first link was
https://rog.asus.com/forum/showthread.php?39927-Stereo-Mix-Not-Capturing-Subwoofer-Audio

While they claim it was only when Stereo Mix was involved that was not my case but the facts fit perfectly with your suggestion. The fix (from only this first search)
MAYBE removing the ASUS sound drivers and use the built-in windows drivers it might help.
The next suggestion was... uh.... use headphones! ROFL
Then one person stated, that setting AudioWizard to Off makes the recording sound perfect, Unfortunately, turning it off didn't help me.


To be clear, the entry marked as the solution explains the issue. The actual correction (recording without a headset and recording the subwoofer to eliminate the tinny sound) will not likely to found. The link in this entry has a POSSIBLE solution, which may cause additional issues, one workaround, and one solution that worked for the poster but not me.

mortemas, one final thanks for your help and your extraordinary perseverance!
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
L Audio 0
M Audio 3
jessitokki Audio 1
rclr Audio 2
kobinath Audio 1
Jmatsumoto Audio 1
tquinnddddddd Audio 1
Drakon_71 Audio 1
Ol'Hippie Audio 5
alexanderisreallygreat Audio 3
H Audio 2
A Audio 1
D Audio 1
H Audio 3
G Audio 2
A Audio 2
R Audio 1
B Audio 1
A Audio 3
G Audio 1
Similar threads
Question When I watch my clips, I noticed my microphone only records the left side, does anyone know how to fix this?
Question Record Audio from 1997 JVC Receiver
Question When I record audio, it is muffled
Question Sennheiser PC8 - distortion when recording
Question MK-F100TL Wired Microphone USB Condenser Sound Recording is not working in my laptop
Question Why won't Record button on dual cassette player push down on player deck?
Question How do I use this cassetdeck to record the audio from it to my computer?
Question How do I stop my microphone from doing this when I record
Question How can I record a phone interview
Question (Novice) What do I need to record audio from a 3.5mm laptop headphone jack into two 3.5 mm mic inputs?
Razer Kraken 7.1 V2 Great Playback in Synapse... disgusting sound/mic quality while ingame/recording...
How Or where do I find audio settings for playback or record With Adobe Audition 1.5
How do I know my system is setup correctly for recording and playbacks?
How do I record game audio, and play it back though my headphone. (Elgato HD 60)
Static/noises my usb headset mic is making. Already tried the recording/playback solution.
Recently bought Insignia NS-PAH5201-C headset, everything enabled, getting no playback sound or recording sound. Help?
How to playback 3m sound recording tape 1/4 " x 1200 ft plastic backin
Tascam 234 Slows to a Halt During Playback / Record
Recorded cds on computer playback like they are scratched
Record - Playback

ASK THE COMMUNITY