Question Samsung TV ethernet connection issues

Dec 30, 2020
3
0
10
0
Hello,

I have a Samsung QE49Q7FAM (out of warranty) that has given me Wi-Fi connectivity problems almost since day one.
A few days ago I finally decided to start using a cabled connection instead and it worked great for all of one day. The next day I had to turn off my router for half an hour or so and since then the wired connection to the TV doesn't work anymore. The Wi-Fi now works fine, though, as long as I set a static IP address and the Google DNS for the TV.
I'd like for the ethernet to work, though, since Wi-Fi reception is spotty at best.

I tried:
  • updating the TV firmware (it's now updated to v1290);
  • setting a static IP address on the TV + the router DHCP settings;
  • resetting network/Smart Hub/to factory settings on the TV;
  • power cycling the router;
  • turning off the TV by removing the plug from the socket and waiting for at least 20 minutes before turning it on again;
  • hard rebooting the TV by keeping the power button pressed on the remote until the Samsung logo showed up (incidentally, this fixed the random message of "cable not connected" even though it was);
  • changing DNS on the TV (using my own home DNS, Google's, Cloudflare's, etc.);
  • probably more I can't remember at the moment.
As soon as I try connecting to the internet with automatic settings, I get 0.0.0.0 in every field. If I retry, I get a weird 169.254.X.X IP (so not internal) and a 255.255.0.0 subnet mask. If I choose my own manual settings it tells me to make sure the DHCP server on the router is on. Which it obviously is.

These are the settings I'm currently trying:
  • IP : 192.168.1.10 (then set in router DHCP settings too, along with the TV MAC address)
  • Subnet mask : 255.255.255.0
  • Gateway : 192.168.1.1
  • DNS : 8.8.8.8
A weird thing I noticed is that on my router page if I connect the TV using Wi-Fi, I see it as "Samsung". If I try using LAN, it shows as "computer". I don't know if that's relevant.

The same ethernet cable works perfectly fine on any other device except the TV.
I'm wondering how turning off and on the router could mess everything up.

I'd really appreciate any advice. I'm pretty desperate. Thank you!
 
Last edited:

COLGeek

Cybernaut
Moderator
Your IP address should be in the same range as the Gateway (the rest of the network). Either change to use DHCP and let an address get assigned or change to something like 192.168.1.101 (or any other un-used 192.168.1.X address).
 
Dec 30, 2020
3
0
10
0
Your IP address should be in the same range as the Gateway (the rest of the network). Either change to use DHCP and let an address get assigned or change to something like 192.168.1.101 (or any other un-used 192.168.1.X address).
Thanks for answering.
It is in the same range. I chose 192.168.1.10, to be exact, which was an unused address. I tried other addresses, too, same range, but nothing changed.
 

COLGeek

Cybernaut
Moderator
Thanks for answering.
It is in the same range. I chose 192.168.1.10, to be exact, which was an unused address. I tried other addresses, too, same range, but nothing changed.
Above you stated a different address. Which is it (169.168.1.10 or 192.168.1.10)?

For most users, DHCP will suffice to simplify these issues. Do you have a whitelist setup on your router to only allow specific devices to connect to your network?
 
Dec 30, 2020
3
0
10
0
Above you stated a different address. Which is it (169.168.1.10 or 192.168.1.10)?

For most users, DHCP will suffice to simplify these issues. Do you have a whitelist setup on your router to only allow specific devices to connect to your network?
Sorry, you're right, it was my mistake. I typed this from my phone and for some reason my keyboard is really laggy on some websites and I didn't check very well what I wrote.
I did mean 192.168.1.10.

I have no whitelist setup on my router. I could maybe try to set one up and see if it works whitelisting MAC addresses for each of my devices, but seeing as its my parents' house even if it did work I couldn't keep it enabled. They don't know how to work half of this stuff and I'm not usually there.
 

COLGeek

Cybernaut
Moderator
Sorry, you're right, it was my mistake. I typed this from my phone and for some reason my keyboard is really laggy on some websites and I didn't check very well what I wrote.
I did mean 192.168.1.10.

I have no whitelist setup on my router. I could maybe try to set one up and see if it works whitelisting MAC addresses for each of my devices, but seeing as its my parents' house even if it did work I couldn't keep it enabled. They don't know how to work half of this stuff and I'm not usually there.
It shouldn't be necessary to create a list for this. I was wondering if one was already in place.

What did you do in relation to this statement?

"then set in router DHCP settings too, along with the TV MAC address"
 
Thread starter Similar threads Forum Replies Date
V Streaming Video & TVs 2
alanjack Streaming Video & TVs 0
J Streaming Video & TVs 0
B Streaming Video & TVs 2
J Streaming Video & TVs 1
mrcin Streaming Video & TVs 0
Luka0404 Streaming Video & TVs 7
N Streaming Video & TVs 1
T Streaming Video & TVs 1
J Streaming Video & TVs 3
M Streaming Video & TVs 1
C Streaming Video & TVs 2
Ricky Steedman Streaming Video & TVs 1
L Streaming Video & TVs 3
Jvasseur1 Streaming Video & TVs 0
T Streaming Video & TVs 8
A Streaming Video & TVs 4
A Streaming Video & TVs 2
N Streaming Video & TVs 6
L Streaming Video & TVs 1

ASK THE COMMUNITY