See white dots jumping on screen after used driver booster 3

d2idan

Estimable
Sep 2, 2015
11
0
4,560
0
I upgraded to windows 10 a week ago.
Eveything was perfect.
Now I used driver booster 3 to update my drivers.

Worst choise I have made.
Now a lot of white dots are jumping over my screen.

Driver booster 3 updated my:
CHIPEST -it got stucked on 14 precents so I restarted and installed again.

Intel HD 5500 DISPLAY ADAPTER

and 3 or 4 more updates.

System restore did not work.

What can I do?
The laptop worked perfectly before I used driver booster.
I have it for a month and a half.
And I just watch movies and compiling light code.

Own a dell Latitude E7450
 

jaytechgaming

Honorable
Feb 3, 2013
30
0
10,580
1
In the future, only install drivers from your manufacturer's support page. I can direct you to the specific downloads if you would like.

Attempt 1: I would try to use a restore point before this program was installed (not sure if that is what you mean by System Restore, but you may simply not have gone back enough).

Attempt 2: Try uninstalling Driver Booster and attempting to uninstall any drivers it installed through "Uninstall a program"

If neither of those work

Attempt 3: Back up all your important data to a separate drive and run a full system wipe and reinstall windows. I can give you more information on this if you end up needing to do it and need help.

A full windows wipe will basically make your computer run like it did when you got it. It may be restored without drivers, in which case you should download the official ones from your manufacturer.
 

d2idan

Estimable
Sep 2, 2015
11
0
4,560
0


system restore didn't work.
formatting my pc didn't work.

I also seeing things like this green thing:
http://imgur.com/a64WrTi

and also this came up:
http://imgur.com/g86346J

when I went to device manager and uninstalled the hd 5500 display adapter driver. everything was good.
but when I updated the driver (must do this ofcourse, and I did it from device manager as well) so now everything is not good again. with white dots jumping and a messege that says :
"display adapter stopped responding and has recovered"
this messege always showing up now.

 

jaytechgaming

Honorable
Feb 3, 2013
30
0
10,580
1


Looks like artifacting. This could be a hardware fault or an issue that occurred by the Drive Booster installing either corrupt, malicious, or incorrect drivers for your hardware.

I cannot find your laptop, are you sure it is the E4750 and not the E7450?



 

d2idan

Estimable
Sep 2, 2015
11
0
4,560
0

its E7450 yes.


when I went to device manager and uninstalled the hd 5500 display adapter driver. everything was good.
but when I updated the driver (must do this ofcourse, and I did it from device manager as well) so now everything is not good again. with white dots jumping and a messege that says :
"display adapter stopped responding and has recovered"
this messege always showing up now. more information:

 

jaytechgaming

Honorable
Feb 3, 2013
30
0
10,580
1


Uninstall the graphics driver and install this one specifically http://downloads.dell.com/FOLDER03202777M/1/Video_Driver_V387Y_WN32_10.18.15.4248_A01.EXE

Also, It looks like your laptop may have an Nvidia card, take a look into that.

 

jaytechgaming

Honorable
Feb 3, 2013
30
0
10,580
1


That is what I directed him to in the previous link. Hopefully that should fix it.
 

derekullo

Distinguished
Jan 25, 2009
137
0
18,660
9
The Dell website has older drivers than the intel site.

Edit:

Pulling up drivers for Intel HD, HD 4000/4200/4400/4600/5000/5100/5200/5300/5500 Graphics Driver at Dell's website shows last Updated 27 Aug 2015.

Pulling up drivers for Intel® Iris™, Iris™ Pro, and HD Graphics Driver for 4th Gen Windows* 10 64bit on Intel's website shows 9/19/2015.
 

d2idan

Estimable
Sep 2, 2015
11
0
4,560
0


I cant, its says when I am trying to install it :

Error: The driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer's manufacturer. Setup will exit.


 

jaytechgaming

Honorable
Feb 3, 2013
30
0
10,580
1


Is your computer 64bit or 32bit? I sent you the 64bit download.
 

derekullo

Distinguished
Jan 25, 2009
137
0
18,660
9
You must uninstall the previous dell driver then install the intel driver.

I had this exact same issue here at work trying to play a game.

With the Dell driver the game would constantly say driver was out of date.

After uninstalling the Dell graphics driver and installing Intel the game did not say the driver was out of date.
 

d2idan

Estimable
Sep 2, 2015
11
0
4,560
0


64 bit . that will not work. I tried everything

 

d2idan

Estimable
Sep 2, 2015
11
0
4,560
0


didn't work.
not only I have red and white dots all over the screen. I also see black and red squere images popping
and after a while. a blue screen with words written says the pc had to commit shutdown because something went wrong
 

jaytechgaming

Honorable
Feb 3, 2013
30
0
10,580
1
You should do option 3 that I wrote before. Move all your data onto a new drive and reinstall Windows. Without sitting down with your computer, there is little I can diagnose.
 

skip_woof

Estimable
Oct 7, 2015
1
0
4,510
0
You can try to contact Driver Booster support and let them help fix this problem.

I also had an update problem before and they solved it quickly.
 
Thread starter Similar threads Forum Replies Date
D Laptop Tech Support 2
V Laptop Tech Support 2
K Laptop Tech Support 0
Rveng Laptop Tech Support 1
Dareom Laptop Tech Support 7
alot12343 Laptop Tech Support 1
L Laptop Tech Support 7
xSPEAR Laptop Tech Support 1
B Laptop Tech Support 0
RodrigoTTD Laptop Tech Support 1
pyrrhicx Laptop Tech Support 1
Poch.t Laptop Tech Support 1
D Laptop Tech Support 10
N Laptop Tech Support 1
snowstorm29 Laptop Tech Support 3
K Laptop Tech Support 2
M Laptop Tech Support 0
EVE3LYNN Laptop Tech Support 1
Loureyna Laptop Tech Support 3
P Laptop Tech Support 0

ASK THE COMMUNITY