Sennheiser game zero special has no surround sound

Aug 6, 2018
5
0
10
0
So a few days ago I decided to buy the sennheiser game zero special edition for $140, and now I’m regretting it. I don’t know if I’m missing something or the headset just doesn’t have surround sound, I have a asus xonar dgx sound card and a msi z97 gaming 5 MoBo that I’ve tried using the headset with for games like fortnite and csgo but I can’t hear where the footsteps are coming from. Don’t get me wrong the quality is good for music and stuff but for games it’s bad without surround sound. I’ve tried using my Astro a40 mixamp and razer surround and still no surround sound. I’ve bought the Astro a40 headset with mix amp like 3 years ago and Ive had no problem with it, but it doesn’t have surround sound. That’s why I bought the sennheiser game zero special edition. But it honestly sounds almost the same, I just don’t get if I’m missing some software or what. My friend is on a laptop and he has the razer krakens but he says he can hear where the footsteps in games are coming from, and I have an actual gaming setup but I can’t hear where footsteps in games are coming from.

I need help with figuring this out, if anyone can help please let me know, you can message me on discord I’m on most of the time it’s @Onik#0736

Thanks
 

SoggyTissue

Prominent
Jun 27, 2017
158
0
710
45
i dont see where the sennheiser game zero special edition says it has surround sound

if you refer to using virtual surround via the interface, it is buggy sometimes. check to ensure you have speaker setup as headphones / 2 speakers when enabling virtual surround.
 

drivinfast247

Proper
May 29, 2018
134
0
160
20
The Sennheiser are stereo headphones. Any surround emulation has to be done prior to sending the signal to the headphones. Your Xonar should have a surround solution.
 
Aug 6, 2018
5
0
10
0
Soggy sorry for down voting you, this is my first time using this website I just missclicked. How do I enable virtual surround and set it to headphones/2 speakers?
 

anort3

Distinguished
Moderator
Obviously make sure the headset is connected to the sound card. In the sound card options you should see something like this:



Make sure Game mode is selected and it should enable Dolby Headphone. That's what you want for gaming. My card is a Xonar Essence STX so the options will be slightly different. You'd want Hi Fi mode or the surround off for music.
 
Aug 6, 2018
5
0
10
0


i dont have those modes you have, i just have HF and GX
mine looks like this https://i.imgur.com/VxGrThM.png
 

anort3

Distinguished
Moderator
Make it 8 channels via the drop down menu ( if you can ).

Change the sample rate to 44.1Khz.

To the right of Analog Out : Headphone is the headphone amp gain setting. The higher it's set the more volume you get.

Uncheck 7.1 Virtual speaker. Click GX. It should light up.


For music. Change to 2 channels in the drop down menu and press Hi Fi.
 
Aug 6, 2018
5
0
10
0
anort3 do you have discord?
you seem experienced so i need help with a few audio things im trying out like my astro a40 with the mix amp+xonar dgx sound card, i cant get this to work after an hour of searching and trying things out.
 

drivinfast247

Proper
May 29, 2018
134
0
160
20
Don't use both the MixAmp and Xonar. Pick one or the other. How do you know its not working?

BTW the Astro MixAmp does have surround sound. Not sure why you said it doesn't.
 
Thread starter Similar threads Forum Replies Date
maveick Audio 4
JackGarrison Audio 1
rclr Audio 2
F Audio 1
K Audio 1
N Audio 26
T Audio 1
N Audio 2
M Audio 10
L Audio 1
M Audio 2
KR2 Audio 1
A Audio 9
M Audio 1
T Audio 1
P Audio 1
AbyssD Audio 6
T Audio 4
N Audio 3
T Audio 8

ASK THE COMMUNITY

TRENDING THREADS