Question Sharp 75" : screen blur and screeching noise followed by reboot

Dec 30, 2020
5
0
10
0
Sharp 75"
model LC-75Q7570U
Android TV OS version 9
Purchased Dec 2018

Starting approximately two weeks ago our 75" Sharp began to have this issue. Without warning screen will scramble and the tv emits a high-pitched screen noise. This usually lasts about 5 seconds and then the TV reboots itself. The timing is random, tonight it happen twice within 20minites of use. A few nights ago we almost made it through a 2 hour movie before it happened.

The problem began approximately two weeks ago after the tv prompted us to accept a software update. Prior to the software update we had not experienced any problems with this set.

I recorded a video and post on YouTube. I'll try to figure out how to post a link.

Has anyone experienced something similar? I'm open to suggestions

Thanks on advance

View: https://youtu.be/hC7nF3Okykc
 

berley

Great
Jan 12, 2021
16
0
60
0
I just had the same issue... Was told they would send me new software download but still waiting. Anyone else have any luck?
 
Jan 12, 2021
5
0
10
0
Sharp 75"
model LC-75Q7570U
Android TV OS version 9
Purchased Dec 2018

Starting approximately two weeks ago our 75" Sharp began to have this issue. Without warning screen will scramble and the tv emits a high-pitched screen noise. This usually lasts about 5 seconds and then the TV reboots itself. The timing is random, tonight it happen twice within 20minites of use. A few nights ago we almost made it through a 2 hour movie before it happened.

The problem began approximately two weeks ago after the tv prompted us to accept a software update. Prior to the software update we had not experienced any problems with this set.

I recorded a video and post on YouTube. I'll try to figure out how to post a link.

Has anyone experienced something similar? I'm open to suggestions

Thanks on advance

View: https://youtu.be/hC7nF3Okykc
I have the same model and exactly the same problem happens right before BlackFriday. Started right after software update. We try to use this TV for couple weeks with this restarts, but finally have broken audio. I bought mainboard for this TV and it mainly fix the problem, but no audio only using external speakers connected to RCA. I had ordered another board (power board) - still waiting delivery from Canada. And today I also was asked for Software Update. I just turn TV off. I am afraid this update may destroy something on mainboard.
 
Jan 12, 2021
5
0
10
0
I have the same model and exactly the same problem happens right before BlackFriday. Started right after software update. We try to use this TV for couple weeks with this restarts, but finally have broken audio. I bought mainboard for this TV and it mainly fix the problem, but no audio only using external speakers connected to RCA. I had ordered another board (power board) - still waiting delivery from Canada. And today I also was asked for Software Update. I just turn TV off. I am afraid this update may destroy something on mainboard.
I also check Sharp/Hisense sites for original firmware but they don't have any information (even user manual) on this model LC-75Q7570U (bought in November 2018).
 

Djnaz

Great
Jan 12, 2021
20
1
65
0
I have the same model and exactly the same problem happens right before BlackFriday. Started right after software update. We try to use this TV for couple weeks with this restarts, but finally have broken audio. I bought mainboard for this TV and it mainly fix the problem, but no audio only using external speakers connected to RCA. I had ordered another board (power board) - still waiting delivery from Canada. And today I also was asked for Software Update. I just turn TV off. I am afraid this update may destroy something on mainboard.
You bought a board before contacting sharp? Just wondering
 
Jan 12, 2021
5
0
10
0
You bought a board before contacting sharp? Just wondering
No. I just search for "old" firmware. After finding nothing decide to replace mainboard (most like it is already broken by this Software Update). Also I had found incorrect voltage came from Power board 24volt instead of 18volt (marked on board)
 

berley

Great
Jan 12, 2021
16
0
60
0
They scheduled a service repair guy to come to the house. Originally was told they would send me new firmware, but when I called back said it requires a technician. Then received email stating that if it is the panel that they will field destroy the television. Any luck from your end?
 
Thread starter Similar threads Forum Replies Date
W TVs 0
C TVs 0
M TVs 0
jumanjijayman TVs 0
Redyns TVs 0
Amell TVs 0
O TVs 0
R TVs 7
sopipopi TVs 2
R TVs 2
J TVs 0
S TVs 1
T TVs 0
Nipper76 TVs 1
natalie g TVs 0
Garritwithani TVs 0
R TVs 0
noeller20 TVs 0
zeus_cesar TVs 0
StormSTI TVs 0

ASK THE COMMUNITY