Sharp Aquos LED TV - black/white screen (no picture) but sound

Jul 25, 2018
1
0
10
0
My LED TV suddenly stopped showing pictures and initially only black screen showed up. But power and sound works fine.
I opened my TV and disconnected and reconnected the ribbon cable, and now it shows white screen with some black lines.
Visually every part under the hood looks good to me.
If I get to know which part has the problem then I can replace and save my TV. Your help will be appreciated.

Please have look at this video to see how it runs right now.
[video="https://www.youtube.com/watch?v=bb9SjDs3xkg&feature=youtu.be"][/video]

Also you can see how the TV looks under the hood in this pic.
Please click here for the Picture.

My TV details:
Sharp Aquos 39 inch LED TV
Model: LC-39LE551U
 

paulchezter

Notable
Aug 11, 2018
252
0
860
86
It is possible that T-con is damaged. Best suggestion is to contact the service center near you for further diagnosis, or if the price of repair is more than the price of a new TV, just buy a new one.
 
Thread starter Similar threads Forum Replies Date
D Streaming Video & TVs 0
T Streaming Video & TVs 16
M Streaming Video & TVs 2
K Streaming Video & TVs 2
G Streaming Video & TVs 1
J Streaming Video & TVs 4
S Streaming Video & TVs 1
T Streaming Video & TVs 2
C Streaming Video & TVs 1
P Streaming Video & TVs 1
R Streaming Video & TVs 2
S Streaming Video & TVs 3
E Streaming Video & TVs 1
M Streaming Video & TVs 1
M Streaming Video & TVs 1
2 Streaming Video & TVs 2
D Streaming Video & TVs 1
A Streaming Video & TVs 2
E Streaming Video & TVs 1
R Streaming Video & TVs 2

ASK THE COMMUNITY