SLI not available after Driver update - 280M's in Alienware M17x

JeremyF

Estimable
May 31, 2015
1
0
4,510
0
So I'm the sad owner of a Dell M17xR3 that hasn't had a driver update since 2010. I was managing with this for years and yesterday decided to use a modded nvidia driver (vs. 340.52) on my 280Ms.


Now, SLI is disabled and I can't seem to enable it....system is defaulting the to the integrated graphics (9400) and I can't make it even use a single 280M, let alone both.

Both of the 280M's are registering in the Device Manager as well as the Nvidia Control Panel, but I can't access them. The message says "SLI disabled" and will not change to the 280M's even when I click the "Maximize 3D performance. The system is running Windows 7 Ulitmate and is completely updated.

I have gone through several clean installs, enabled and disabled the hybrid graphics in the bios as well as enabled/disabled the PCI/Gen 2 option there as well - all of this to no avail.

Suggestions?
 

Phillip Corcoran

Splendid
Moderator
Your Dell will only work properly with drivers from Dell's website as the components are custom-made for Dell which means only Dell has the correct drivers.

First of all, roll back the GeForce/Nvidia driver to the previous version by using Device Manager:

Open DM.
Double-click on the Nvidia or GeForce item under 'Display Adapters'.
Click on the 'Driver' tab.
Click on 'Roll back driver' button.

If everything then returns to normal, leave the driver alone, or check the Dell website for a newer version if you really can't resist updating it.

Provided an existing driver is working properly, it really doesn't matter how old it is. Updating a driver just because there is a newer version is not a sufficiently good reason to go ahead with it.

"If it aint broke, don't fix it!"
 

Blitz86

Estimable
Aug 2, 2015
3
0
4,510
0
Hey,
You could listen to that,
I have same laptop and have done like you used drivers not meant for it,
You should 1st confirm there is not hybrid graphic settings running in bios.
Same with integrated turn that stuff off and get back and try again.
 
Thread starter Similar threads Forum Replies Date
L Laptop Tech Support 3
G Laptop Tech Support 5
O Laptop Tech Support 2
P Laptop Tech Support 5
K Laptop Tech Support 1
A Laptop Tech Support 3
B Laptop Tech Support 6
O Laptop Tech Support 1
A Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 1
K Laptop Tech Support 3
H Laptop Tech Support 1
N Laptop Tech Support 1
stefjohn2k17 Laptop Tech Support 2
nashvilletngirl Laptop Tech Support 1
F Laptop Tech Support 16
T Laptop Tech Support 1
Similar threads
Question Asus Laptop screen LCD's not turning on after driver update
Question display adapter cant update from basic driver
Question Toshiba p50 no sound after driver update
Question Which updated graphics driver should I install from intel's website?
Solved! Is it bad to update Nvidia driver updates using Geforce experience?
Recently I have installed updated graphics driver Amd Radeon HD 7670M to the latest version, and popping up the Blue screen of
Black screen on external monitor for laptop after driver update
Will downloading the driver update download make the laptop start up on its own without being plugged in? The screen isn't th
My amd graphics card m230 in my laptop keeps crashing after i update its new driver from amd site...pls help me to solve this
I update de Graphics C. Driver and my laptop screen turn black
When I update my laptops drivers, the screen freezes every couple seconds
After updating amd driver, keyboard and touchpad stopped working
Amd driver update
I can not get my dell computers wi fi to stay on i have updated the driver and still no luck
I updated my Realtek Audio Drivers, and now no sound will come through my headphones/headset
Laptop black screen after updating Drivers
Black screen after windows 10 logo (after gpu drivers update)
Intel says update video driver. Acer says no and doesn't provide an alternative. Fix? [Screenshots]
BSOD's after updating Nvidia drivers! High Temps too! [ASUS GL552VW]
Windows 10 update wiped my audio drivers on my HP Pavillion DV7

ASK THE COMMUNITY