Slow WiFi on Laptop fast on other devices

Feb 16, 2018
6
0
10
0
Hello, I bought new WiFi adapter- TP- Link AC 1750 Wireless Dual Band Gigabit Router
Archer C7. Internet speed is going really slow on my HP laptop but fast on other devices like phones other laptops and TV. I check it here: http://www.speedtest.net/

I tried literally everything.. My router location is not near any other device. I reset DNS, I use latest drivers I changed my Broadcom driver to his previous version but there was no effect so I updated it. I reset my router and laptop to their factory. I use 11th channel, 40 mHz width (I tried on 20 and auto also), my mode is 802.11 b/g/n mixed (tried g/n and n only). My Broadcom properties: bandwidth capability is 11b/g:20/40MHz (tried on 20 only also), IBSS Mode is 802.11b/g/n Auto, XPress (TM) Technology is enabled. Power Management: Allow the computer to turn off this device to save mode is not set. I called TP- Link support and they connected to my laptop through Team Viewer and checked my setting and my WiFi was slowing down again. When I disconnect it from the laptop and connect to it again the wifi is perfect for couple seconds and then it's slow. It is 0,5-2 Mbps. I didn't have that problem on my old adapter. I use 2.4 Ghz on this laptop. I checked the speed from my other devices on 2.4 Ghz also

My laptop is HP Envy. Intel i7- 4720HQ CPU, 8GB RAM.
 

Barty1884

Admirable
Moderator
You linked the website, not your results specifically.

What laptop model do you have specifically? From some quick searches, it would appear the HP Envy 15t (which would match your spec) uses a Realtek Wifi chip, not Broadcom.
 
Feb 16, 2018
6
0
10
0
http://www.speedtest.net/result/7064783112 -fast
http://www.speedtest.net/result/7064794255 -slow (I haven't changed anything, this is just now)

HP ENVY 15 Notebook PC
OS: Windows 10 Home 64-bit
Microprocessor: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz
System memory: 8GB
Video:
Intel(R) HD Graphics 4600
Graphic memory: 2,161 MB
When I go to Device Manager it shows:
Broadcom BCM43142 802.11 bgn Wi- Fi Adapter
Realtek Pcle GBE Family Controller
 
Feb 16, 2018
6
0
10
0


http://www.speedtest.net/result/7064783112 -fast
http://www.speedtest.net/result/7064794255 -slow (I haven't changed anything, this is just now)

HP ENVY 15 Notebook PC
OS: Windows 10 Home 64-bit
Microprocessor: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz
System memory: 8GB
Video:
Intel(R) HD Graphics 4600
Graphic memory: 2,161 MB
When I go to Device Manager it shows:
Broadcom BCM43142 802.11 bgn Wi- Fi Adapter
Realtek Pcle GBE Family Controller


 
Feb 16, 2018
6
0
10
0
I found something out. When my wireless speed is good and I play 4k or 8k video on youtube my Laptop's fans are going loud, the video is playing for couple second well and then stops, my speed drops to 1-2 Mbps and the fans are not loud anymore . When I reconnect to the WiFi my speed is good again. When I have video conversation on Facebook I have the same problem. Any ideas?
 
Feb 16, 2018
6
0
10
0


There is no solution.. The laptop lan card isn't working good with the wifi adaptor. I bought acer predator and it is working perfect on same wifi.

 
Aug 19, 2018
1
0
10
0


I am facing the same problem. But when I connect my hp pavilion laptop with my mobile hotspot, Internet works fine. The speed is same as it is on mobile. On the other hand, when I connect it to my router, the speed is never stable.

 
Thread starter Similar threads Forum Replies Date
Alwise901 Laptop Tech Support 3
T Laptop Tech Support 1
D Laptop Tech Support 4
L Laptop Tech Support 5
A Laptop Tech Support 2
D Laptop Tech Support 2
EndlessZone123 Laptop Tech Support 5
D Laptop Tech Support 1
S Laptop Tech Support 2
G Laptop Tech Support 1
M Laptop Tech Support 1
P Laptop Tech Support 4
M Laptop Tech Support 1
D Laptop Tech Support 3
B Laptop Tech Support 1
B Laptop Tech Support 1
C Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY