So... my headset's sound doesnt work properly when fully plugged in.

Christopher Abrego

Estimable
Apr 25, 2015
2
0
4,510
0
I'm sorry, I'm new here, so i may be placing this in the wrong forum and such.

Anyway, my headset suddenly(yesterday) started giving me this issue where, when fully plugged in, I cannot hear most of the audio from my computer/anywhere. I can when it isn't fully plugged in, but it sounds muffled and low quality.

I've tried with other things, like other PC jacks and such, and I've even tried another headset in this PC, and and all signs say it's the headset. Anyway to find out what my problem is/solve it?
 

Christopher Abrego

Estimable
Apr 25, 2015
2
0
4,510
0


I do, and that's a decent semi solution, but the audio doesn't come out completely properly still, and it leaves the wire loose and it easily falls out.
 

holyprof

Distinguished
Dec 16, 2011
22
0
18,570
4
Clearly it's a broken or a short-circuited wire, usually close to the jack. It's easy to repair with the right tools and some experience. I repaired 5 or 6 broken cables in the last months. Too bad you live in a distant country. Don't take them to repair shop, the cost will probably be around $20 or more, so better ask a friend to repair them or just buy new ones.

The muffled low quality sound you hear indicates the ground (common) wire is broken.
 
Thread starter Similar threads Forum Replies Date
CatTheMightyLord Audio 0
S Audio 1
V Audio 1
pbeans Audio 0
D Audio 0
R Audio 0
D Audio 1
Vexzionel Audio 3
Kartunz Audio 6
Maria223 Audio 0
B Audio 7
twissen Audio 4
G Audio 1
A Audio 1
G Audio 1
F Audio 0
Spark3 Audio 1
X Audio 1
I Audio 7
1 Audio 1

ASK THE COMMUNITY