Speakers on my laptop crackling/popping.

AmnesiaDaniel

Honorable
Dec 15, 2013
4
0
10,510
0
I own a Dell Inspiron 7567 with Windows 10 64-bit and a couple days ago my laptop's internal speakers started crackling/popping for no apparent reason. The weird thing is that the crackling/popping is present even over headphones/earphones.

I'm currently using Realtek Audio drivers.

POSSIBLE FIXES I'VE ALREADY TRIED:

> Re-installed drivers (both from the Realtek's and Dell's website), the issue still persists.

> Tried fooling around in the Sound Playback settings, tried changing the sound quality from Studio to CD, still nothing.

> Someone suggested me to try changing my power settings and set Minimum Processor State to 100% for both On Battery and Plugged. No luck.

NOTES:

> When I revert back to the default drivers ('High Definition Audio Device'), I notice no crackling. However, the internal subwoofer doesn't work with the default drivers and I can't use MaxxAudioPro with it.

> I don't know if it's relevant, but a couple hours ago I was noticing no crackling. But suddenly, without any notice, I hear a 'click' noise and my laptop shuts down immediately. It reboots on it's own and the crackling is back.

Any help will be appreciated, it's hard living with terrible audio.
Thanks.
 

AdonosFlew

Estimable
Jul 11, 2015
3
0
4,520
1
There is a service tag on the bottom of your laptop something like ~6 digit code. Make sure that on dell's support page you search the drivers based on the service code so you get the exact drivers for your components. Maybe check if there's a software for realtek audio driver which could change the EQ. Maybe the default EQ is the problem. Is the laptop shutted down with a BSOD? If yes, please tell us the error code.
 

AmnesiaDaniel

Honorable
Dec 15, 2013
4
0
10,510
0
Yep, the service tag matches the one on the website. IIRC Realtek used to have a Realtek HD Audio Manager, but I can't find it anywhere for Windows 10.

Nope, no BSOD. It just shut off instantaneously with a click noise and rebooted, giving me the option of restarting in Safe Mode.
 
May 11, 2018
1
0
10
0
The solution for me was to disable SmartByte - windows - search - off. Smartbyte is an app to route your internet speed to much needed places, turns out this was creating the popping sound for me.
 
Aug 4, 2018
1
0
10
0


I NEVER THOUGHT THIS WAS THE PROBLEM. THANK YOU SO MUCH YOU ARE A LIFESAVER!!!!!
 
Oct 9, 2018
6
0
20
1
RealTek driver [watch your language] up a lot of speakers and mic including mine..
I think the best solution is using the Microsoft High definition audio driver since its the best one untill realtek updates their driver!
 
Oct 22, 2018
1
0
10
0


Disable Smartbyte solve my problem ! Thanks. Guides to disable Smartbyte below:

1) search for "services" in window search bar
2) look for "SmartByte Network services"
3) right click properties, and select startup type to "disable".
 
Thread starter Similar threads Forum Replies Date
Haruki-Man Laptop Tech Support 5
Radishfarmer Laptop Tech Support 1
RASHI_27 Laptop Tech Support 1
L Laptop Tech Support 1
A Laptop Tech Support 2
S Laptop Tech Support 1
R Laptop Tech Support 3
S Laptop Tech Support 1
EndlessZone123 Laptop Tech Support 5
A Laptop Tech Support 1
M Laptop Tech Support 1
D Laptop Tech Support 12
W Laptop Tech Support 1
M Laptop Tech Support 1
J Laptop Tech Support 4
B Laptop Tech Support 1
D Laptop Tech Support 3
K Laptop Tech Support 1
D Laptop Tech Support 1
Mizuki1408 Laptop Tech Support 16

ASK THE COMMUNITY