Solved! Tablet stuck in powered by Android screen

Not open for further replies.
May 20, 2018
I tried pushing power button and then the volume button down and nothing happened is there can get to the safe mode or am I what am I doing something wrong 8. A I can get to the recovery section by holding down the power button and the volume button when it comes on but then I'm not sure what to do after I reset the partition I get to the screen where it says Reboot system now reboot to Bootloader apply update from USB c c b and then partition and reset the data wipe data factory reset Mount systeam but don't know what to do then I like the partition and I wipe the factory reset now what do I do
thank you for your input but I think this is under warranty cuz it's not working with me to do I'll be better off just taking it back I don't know if I can take it back and send it to the manufacturer but yeah it's less than 2 months old
To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.

If it loads, then you know the problem is software related. Bad app, virus, malware, etc. Which you would need to remove to fix the problem. However, if it still won't load, even in "Safe Mode", then it may well be in need of a full "Hard Reset" or have a hardware issue.
NOTE: Doing this will clear 'all' the data on your tablet, so it is suggested you not choose this option unless you have to, or aren't worried about losing anything on the device.

Be sure you back up any data you want to keep, to a computer or cloud account, before doing the reset.

To "Hard Reset" the tablet...

1. Make sure that the tablet is actually powered off.

2. Remove your SD card, if there is one in the device.

3. Press the "Power" and the "Volume Up" buttons, together, until you see the start-up logo on the screen.

4. Once you can see the logo, release the buttons and allow the device to enter the "System Recovery Mode".

5. Next use "Volume Down" button to get to the "wipe data/factory reset" option When in recovery mode the "Volume Up" and "Volume Down" buttons are how to can navigate and highlight what option you need.

6. Once you have selected the "wipe data/factory reset", press the "Power" button to select that option.

7. On the following screen, repeatedly press the "Volume Down" button until the "Yes - delete all user data" option is what is selected.

8. Then press the "Power" button to hard reset the tablet.

9. If you took your SD card out in step 2, when the device is up and running again, reinsert the SD card.
Jun 30, 2018
I have a nextbook ares 8 and have tried all of that. It still stays at the logo screen. I can get into the recovery screen but nothing happens when i try any of the options. So is my tablet screwed or is there something else I can try.
Not open for further replies.
Thread starter Similar threads Forum Replies Date
johnf52 Android Tablets 1
woodhead666 Android Tablets 0
I Android Tablets 2
Shenelby Android Tablets 1
scwolves10 Android Tablets 5
Sia111 Android Tablets 6
R Android Tablets 1
P Android Tablets 1
M Android Tablets 1
M Android Tablets 1
L Android Tablets 1
J Android Tablets 10
S Android Tablets 1
S Android Tablets 1
M Android Tablets 1
N Android Tablets 3
Q Android Tablets 1
J Android Tablets 3
A Android Tablets 3
B Android Tablets 1