Solved! Technics receiver overload

Status
Not open for further replies.

sgbartley

Distinguished
Jan 16, 2010
2
0
18,510
0
This is a Technics SAGX 190 been in use for many years with no problems. Recently it started saying tape monitor overload please turn off.
 

JAYDEEJOHN

Distinguished
Moderator
Aug 23, 2006
96
0
18,590
3
Sounds like its just getting old, or electromigration, where the electrons have simply worn away the silicon or even the connects over time. Also, possibly a heat issue as well, making for underpowered scenario, as the heat goes up, the voltage goes down.
Try cleaning it if you can get to it.
If its bad when only in usage, then it could be a mechanical issue as well, as over time, and sooner as well, mechanical systems break down and wear out
 

JAYDEEJOHN

Distinguished
Moderator
Aug 23, 2006
96
0
18,590
3
Sounds like its just getting old, or electromigration, where the electrons have simply worn away the silicon or even the connects over time. Also, possibly a heat issue as well, making for underpowered scenario, as the heat goes up, the voltage goes down.
Try cleaning it if you can get to it.
If its bad when only in usage, then it could be a mechanical issue as well, as over time, and sooner as well, mechanical systems break down and wear out
 

sgbartley

Distinguished
Jan 16, 2010
2
0
18,510
0

I will clean it and see if that helps if not time to join the 21st century - Thanks
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
R Audio 0
samyt485 Audio 2
L Audio 1
P Audio 2
O Audio 1
B Audio 4
T Audio 4
B Audio 3
V Audio 1
L Audio 1
J Audio 4
J Audio 2
T Audio 4
L Audio 2
K Audio 2
J Audio 1
K Audio 1
I Audio 1
G Audio 1
R Audio 8

ASK THE COMMUNITY