Terminal Services Client Port Address

G

Guest

Guest
Archived from groups: microsoft.public.pocketpc (More info?)

Just to give our friendly crackers another minor challenge, we've
changed the default port for RDP sessions on all our servers. (VPN
tunnelling next on the list but changing the port was a quick and dirty
option I could do right away).

All working OK for desktops, but now I discover that the Client on my
PDA iPAQ 4150 witn WM2003 won't accept a port identifier on the IP
address line so there goes my mobile support option --AAARGH!

I understand from a bit of searching that there was a registry tweak for
PPC2002 but that it doesn't work with 2003.

Any ideas? Is there a third party client that works OK??

Thanks

(Also posted to the MS Terminal Services client group)
 
G

Guest

Guest
Archived from groups: microsoft.public.pocketpc (More info?)

The registry hack works on my iPAQ 5555 running WM2003... You should make the registry change then
soft reset the iPAQ. See the "How to change the Remote Desktop Listening Port - PocketPC Note"
section near the bottom of this page...

http://theillustratednetwork.mvps.org/RemoteDesktop/RemoteDesktopSetupandTroubleshooting.html

You can also try the Tweaks2K program...See Hack 81...

http://www.tweaks2k2.com/downloads.htm

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"StuffJustHapens" <StuffJustHappens@youkaytwodotnetuk2.net> wrote in message
news:ctd6va$f9f$1@sparta.btinternet.com...
> Just to give our friendly crackers another minor challenge, we've changed the default port for RDP
> sessions on all our servers. (VPN tunnelling next on the list but changing the port was a quick
> and dirty option I could do right away).
>
> All working OK for desktops, but now I discover that the Client on my PDA iPAQ 4150 witn WM2003
> won't accept a port identifier on the IP address line so there goes my mobile support
> option --AAARGH!
>
> I understand from a bit of searching that there was a registry tweak for PPC2002 but that it
> doesn't work with 2003.
>
> Any ideas? Is there a third party client that works OK??
>
> Thanks
>
> (Also posted to the MS Terminal Services client group)
 

CJ

Distinguished
May 4, 2004
36
0
18,580
0
Archived from groups: microsoft.public.pocketpc (More info?)

StuffJustHapens <StuffJustHappens@youkaytwodotnetuk2.net> wrote:

>Just to give our friendly crackers another minor challenge, we've
>changed the default port for RDP sessions on all our servers. (VPN
>tunnelling next on the list but changing the port was a quick and dirty
>option I could do right away).
>
>All working OK for desktops, but now I discover that the Client on my
>PDA iPAQ 4150 witn WM2003 won't accept a port identifier on the IP
>address line so there goes my mobile support option --AAARGH!
>
>I understand from a bit of searching that there was a registry tweak for
> PPC2002 but that it doesn't work with 2003.
>
>Any ideas? Is there a third party client that works OK??

Edit the following registry key...

[HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default]

Add a DWORD value named "Server Port" and enter the new port number
you want to use.

Works fine on my X30 running WM2003 SE!

/CJ
 
G

Guest

Guest
Archived from groups: microsoft.public.pocketpc (More info?)

Sooner Al wrote:
> The registry hack works on my iPAQ 5555 running WM2003... You should
> make the registry change then soft reset the iPAQ. See the "How to
> change the Remote Desktop Listening Port - PocketPC Note" section near
> the bottom of this page...
>
> http://theillustratednetwork.mvps.org/RemoteDesktop/RemoteDesktopSetupandTroubleshooting.html
>
>
> You can also try the Tweaks2K program...See Hack 81...
>
> http://www.tweaks2k2.com/downloads.htm
>

Thanks!
 
G

Guest

Guest
Archived from groups: microsoft.public.pocketpc (More info?)

CJ wrote:

> StuffJustHapens <StuffJustHappens@youkaytwodotnetuk2.net> wrote:
>
>
>>Just to give our friendly crackers another minor challenge, we've
>>changed the default port for RDP sessions on all our servers. (VPN
>>tunnelling next on the list but changing the port was a quick and dirty
>>option I could do right away).
>>
>>All working OK for desktops, but now I discover that the Client on my
>>PDA iPAQ 4150 witn WM2003 won't accept a port identifier on the IP
>>address line so there goes my mobile support option --AAARGH!
>>
>>I understand from a bit of searching that there was a registry tweak for
>> PPC2002 but that it doesn't work with 2003.
>>
>>Any ideas? Is there a third party client that works OK??
>
>
> Edit the following registry key...
>
> [HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default]
>
> Add a DWORD value named "Server Port" and enter the new port number
> you want to use.
>
> Works fine on my X30 running WM2003 SE!
>
> /CJ
>

Thanks!
 

ASK THE COMMUNITY