Question ThinkP T420 works normally only when on Series 3 docking station. When it is undocked, the machine is dead.

wxo

Jun 14, 2021
3
0
10
0
Lenovo ThinkPad T420 running latest Windows 10 normally runs docked on a 433710U Mini Dock Series 3 docking station. It has run this way for years. Until recently, undocking and re-docking have worked flawlessly. However, now when I undock the ThinkPad, it is unresponsive. No amount of holding or pushing of the power button will bring it back to life, but put it back into the docking station and it will resume normal operation. I also tested it on another of the same docking station it worked normally, too.
Again, when I removed it from this docking station, it became unresponsive. I have had no luck with extensive internet searches. This machine acts like it is still docked when removed from the docking station. What am I missing here?
 

wxo

Jun 14, 2021
3
0
10
0
This scenario provides the most information:
Starting with Win10 running normally on the Dock, I eject the T420 ThinkPad. Once off the dock, I open the ThinkPad and the display is active showing everything as it was on the dock. A USB mouse works, wifi is active, browser works, but the keyboard is not functioning. I shut down Win10 and now it will not power up again. It's dead.
Next I plug it into the docking station and power it up through the docking station and it powers up and boots normally. Everything works again.
Next I shut down Win10 and then eject the ThinkPad from the dock. Now it's dead again. No amount of power button pushing or holding will bring it to life.
The machine will only function normally on the docking station.

More info: Not knowing whether these docking stations require a Windows 10 driver, I installed the Lenovo Service Bridge and ran it to check the status of all the drivers in the T420. The result was all my drivers were up to date. However, I was unable to determine if there is a driver involved here or not.
 
Last edited:

AlHuneke

Commendable
Jul 7, 2020
660
77
1,390
76
Sorry for the late response--I've been away. I am stumped. While the keyboard being inactive could be driver related, I can't understand why it won't turn on when undocked. Is the external charger plugged in when you try? The power button must be working since you can turn it off. Running the Lenovo app to check the drivers was a good idea. Regarding need for a dock driver, that is likely but I can't speak to the specific laptop you have.

My next suggestion would be to try a Lenovo specific forum if you have not already done so.
 
Thread starter Similar threads Forum Replies Date
I Laptop Tech Support 0
pNIC Laptop Tech Support 1
I Laptop Tech Support 1
XaniteBlank Laptop Tech Support 1
Dakke Laptop Tech Support 0
G Laptop Tech Support 0
L Laptop Tech Support 0
T Laptop Tech Support 0
T Laptop Tech Support 6
S Laptop Tech Support 2
Larice19 Laptop Tech Support 0
ModyDody Laptop Tech Support 6
Z Laptop Tech Support 0
Karan Malik Laptop Tech Support 3
I Laptop Tech Support 1
Maclik_M Laptop Tech Support 13
B Laptop Tech Support 1
Capturis Laptop Tech Support 0
Michael@Jensen@WK Laptop Tech Support 1
Jor2745 Laptop Tech Support 0

ASK THE COMMUNITY