Question Toshiba 55L621U won't turn on properly

Mar 8, 2020
5
0
10
0
Hi. I recently got this tv and it is giving me problems. When first turned on it works fine, then after the splash screen shuts off completely. The red light blinks 8 times and then stays solid red for about 30 seconds then turns off. No power button on the tv/remote seems to work after this. Below is a YouTube video showing the issue. Any suggestions would be great!
View: https://www.youtube.com/watch?v=Bz9fHYVVc04
 
Apr 2, 2020
3
0
10
0
Hi.any solutions yet. I have the same television model and have the same issue right around the same time you had yours ironically. Had it for about two-and-a-half years I've read so many things I change the power supply board that wasn't it and I change the t-con board that didn't fix a problem. Fortunately for me I just been plying the parts off of eBay and if they don't work I've been fortunate enough to resell them back so I'm not stuck with the parts just wondering did you have any luck what your television issue I would hate to try to redo the firmware as someone suggested on your page and that's not the problem
 
Apr 23, 2020
2
0
10
0
I (along with many others I’m finding) am having this exact same issue with the 55L621U which leads me to believe it is indeed a firmware issue and nothing hardware related (unless these TVs were all designed to fail at the same time!) - I tried flashing the firmware that Toshiba has on their website but it goes to 20% and fails…I’m guessing this is due to the firmware being an old version and the TV not allowing a downgrade - that said has anyone found a firmware that will work? The version I tried is 20170830113420_update_casttv_uhd_01.04.088_fy17_sc_init_clear.prg which is obviously an old (possibly the original) version. Anyone with a working version out there? Thanks much!
 
Hi.any solutions yet. I have the same television model and have the same issue right around the same time you had yours ironically. Had it for about two-and-a-half years I've read so many things I change the power supply board that wasn't it and I change the t-con board that didn't fix a problem. Fortunately for me I just been plying the parts off of eBay and if they don't work I've been fortunate enough to resell them back so I'm not stuck with the parts just wondering did you have any luck what your television issue I would hate to try to redo the firmware as someone suggested on your page and that's not the problem
only things to replace would be the backlight itself and the motherboard


I (along with many others I’m finding) am having this exact same issue with the 55L621U which leads me to believe it is indeed a firmware issue
TVs really fail very often right after the warranty expired. That´s because the used hardware is not designed to last very long and can be very sensible to:
transporting/moving around, temperature,....
If you´ve got the same problem, how can you try updating the firmware?
 
May 11, 2020
1
0
10
0
Hi.any solutions yet. I have the same television model and have the same issue right around the same time you had yours ironically. Had it for about two-and-a-half years I've read so many things I change the power supply board that wasn't it and I change the t-con board that didn't fix a problem. Fortunately for me I just been plying the parts off of eBay and if they don't work I've been fortunate enough to resell them back so I'm not stuck with the parts just wondering did you have any luck what your television issue I would hate to try to redo the firmware as someone suggested on your page and that's not the problem
I replaced everything! All cables and All boards! Same thing! Do not buy any parts. Does the same splash screen and goes back off. Been to a lot of sites where nobody was able to fix it. I think it was a Chrome cast update that bricked the TV. Lot of user from 11/19 to 4/15/20 have the same issues. With the cost of power board or main board lots of people have just bought a new TV. I paid $100 for ALL the components from a broken screen 55L621U. Tested each component as I switched them out (even pwr/imput button, wifi, 3 boards, and all wires) to no avail. Power on splash screen the black screen and power off. No support on this one. Best Buy 389 for a new one.
 
Thread starter Similar threads Forum Replies Date
Jpat TVs 0
mariusica1 TVs 0
K TVs 0
T TVs 0
A TVs 1
Axellion TVs 1
W TVs 1
Carla D70 TVs 3
Vicki Lewis TVs 1
N TVs 1
W TVs 3
A TVs 1
Bangfes TVs 1
K TVs 1
B TVs 2
N TVs 1
B TVs 1
MukhlisM TVs 2
itsgeeeee TVs 1
CruzzieQ TVs 1

ASK THE COMMUNITY

TRENDING THREADS