Toshiba L75-B7270 will not power up

Rhyus

Prominent
Jun 9, 2017
4
0
510
0
I just upgraded my RAM in this laptop. I purchased this from Amazon:

G.Skill Ripjaws Series Laptop Memory F3-1600C9D-16GRSL 16GB (2 x 8G) DDR3 SO-DIMM 1.35v Dual-channel

I installed the memory and turned it back on and all I get is the power light will turn on for about 10 seconds and it will turn back off. I hear the fan start,and hard drive spin up but no Toshiba splash screen. I tried putting the old RAM back in, but I get the same thing happening. There is no sound. While plugged into the outlet or off battery power, whether it is closed or not, it will keep doing this.

I'm at a loss here, as I rarely do work on laptops, but this seemed clear cut and simple. Any help would be appreciated.
 

Faike

Prominent
Mar 27, 2017
3
0
510
0
Are you sure you seated your ram properly? It sounds like improperly seated ram. I would also unplug your battery and your power and hold down the power button for 30 seconds then try booting it again. See if it's the hard drive by using a bootable USB. I only have had this issue with improperly seated ram.
 

Rhyus

Prominent
Jun 9, 2017
4
0
510
0
I've taken the RAM out several times and reseated them. I've even went and tried putting back the original stick and did same thing.
 

Rhyus

Prominent
Jun 9, 2017
4
0
510
0
I'm also curious about that memory. It is what came up when I put in my laptop, but I've had a few people ask me if that is the correct memory. Here is the link of where I bought it:

https://www.amazon.com/G-Skill-Ripjaws-F3-1600C9D-16GRSL-SO-DIMM-Dual-channel/dp/B00EOTYZOA/ref=sr_1_fkmr2_1?ie=UTF8&qid=1497017699&sr=8-1-fkmr2&keywords=toshiba+satellite+l75-b7270+memory

And this is a link to the one Crucial says from their brand will work:

http://www.crucial.com/usa/en/toshiba-memory/ct2kit102464bf160b?cm_cr=No+Campaign-_-Web+Activity-_-us-mfr-toshiba-popular-_-oem_toshiba_compatibleupgrades_mid-_-Crucial+16GB+Kit+%282+x+8GB%29+DDR3L-1600+SODIMM

They seem to be the same, but not certain.
 

Rhyus

Prominent
Jun 9, 2017
4
0
510
0
Ok, so I took my laptop into work today and they looked it over. It seems that the slot that the original memory module was in has gone bad. Not sure how that happened, since the it was being used.
 

Faike

Prominent
Mar 27, 2017
3
0
510
0
You might have not securely seated the ram properly and may have broken the seats that clip it in.
 
Thread starter Similar threads Forum Replies Date
J Laptop Tech Support 0
Adele K Laptop Tech Support 1
CookieSecretz Laptop Tech Support 1
M Laptop Tech Support 1
Yishai Laptop Tech Support 0
T Laptop Tech Support 2
M Laptop Tech Support 5
junior31210 Laptop Tech Support 1
S Laptop Tech Support 2
ramseylacey24 Laptop Tech Support 1
Neon The (Anthro) Umbreon Laptop Tech Support 3
W Laptop Tech Support 1
G Laptop Tech Support 15
H Laptop Tech Support 1
FracturedCode Laptop Tech Support 5
BenKnack2468 Laptop Tech Support 1
justin0106 Laptop Tech Support 7
S Laptop Tech Support 4
tiltawhirl Laptop Tech Support 1
A Laptop Tech Support 4

ASK THE COMMUNITY