Toshiba Satelite L655d - black screen after toshiba logo/splash screen

b-bwoy425

Estimable
Jun 5, 2014
4
0
4,510
0
The laptop would turn on, I would see the option for the bios menu and the boot menu on the Toshiba splash screen, but then once the screen clears, i see a little cursor blink about 4-5 times, then the screen just stays black. I thought it was a very bad virus, so i pulled the HDD out and cleaned it up. I reinserted it. When i go to the bios menu, i am able to see the hard drive, all of the RAM and the cpu. I've tried pulling out the ram sticks (each one at a time, then both). No luck same issue, and when i go to the boot menu and select boot from HDD, it gives the same black screen. I am able to boot from a bootable USB drive to load a windows 7 startup repair. But it doesn't find any problems. What could be wrong? I want to avoid formatting/reinstalling.

**I've also pulled the battery out, held the power button for 30 seconds, then reinserted the battery and powersupply, and tried to turn it on, same problem.
 

b-bwoy425

Estimable
Jun 5, 2014
4
0
4,510
0
Tried that and it didn't work, i kept getting a message saying "Missing Operating System". I figured a virus must have deleted some very critical start-up files. So i went ahead and backed up the user data, and reinstalled windows 7. No problems since then (knock on wood).
 
Thread starter Similar threads Forum Replies Date
tiltawhirl Laptop Tech Support 1
J Laptop Tech Support 2
B Laptop Tech Support 1
D Laptop Tech Support 1
E Laptop Tech Support 3
R Laptop Tech Support 1
A Laptop Tech Support 1
O Laptop Tech Support 1
D Laptop Tech Support 1
J Laptop Tech Support 1
D Laptop Tech Support 2
D Laptop Tech Support 1
B Laptop Tech Support 1
P Laptop Tech Support 1
J Laptop Tech Support 1
D Laptop Tech Support 1
I Laptop Tech Support 1
B Laptop Tech Support 1
M Laptop Tech Support 1
P Laptop Tech Support 2

ASK THE COMMUNITY