Toshiba Satellite A350 laptop

Stigosore

Commendable
Apr 26, 2016
2
0
1,510
0
Ok, here’s the story. I own a Toshiba Satellite A350 laptop for a few years. As every night, laptop was on, I press the power button making it go into hibernate and then pull out the plug (battery is out, since it is always on cable and it might save the battery)

The next day, I plug in the adapter, press the power button and nothing happens. Literally nothing. Black screen, not a single sound .. nothing. All I can see is the indication light that the adapter is plugged in, which lights up.

I searched the internet (using another PC, duh ;) ) and found lots of similar issues with Toshiba laptops. Main solution seems to be holding the power button for 30 second, putting the battery in and restarting it. None of these methods help.

I took the laptop apart, checked (and disconnected) the CMOS battery. Checked the power button, which is working, cleaned everything.

Here’s the weird thing: I have an USB optical mouse and a keyboard connected. I noticed that –besides the indication of the adapter- the red light of my mouse is on all the time and also the indication lights (caps lock, num lock) of my keyboard can be switched on. So there seems to be power on my USB as soon as I connect my adapter.

Hope anyone can help, because I ran out of options. Two friends looked into it, no one has a clue.

 
Hi,

Please do try these troubleshooting steps that may help.
- Start by doing a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again.
- If this will not work, do test the AC adapter if it's working properly. Remove the battery and power the laptop with just the AC adapter connected and see if it will boot up or not. do also try a different AC adapter that has the same voltage and see if it will work or not.
- Proceed with reseating the RAM's if trying a different AC adapter will not work, remove them all for couple of seconds then put them back in making sure everything is seated properly.
- If it will still not work, connect an external monitor and see if you'll get any display from it. If there's a display on the external monitor that could mean that the problem is the built in display.
- But if there's still no display on the external monitor that means the problem lies in the motherboard.

Here's also a video guide on how to disassemble the laptop.
https://www.youtube.com/watch?v=R4Qq8TbLYcI
 

Stigosore

Commendable
Apr 26, 2016
2
0
1,510
0
Hi Laptop_nerd (sorry, there was no need to insult you),
I tried all those things:
- did the trick by holding the button
- measured the adapter, exchanged the adapter.
- removed RAM, removed HDD, removed everything, checked the on-button, measured (and disconnected) the CMOS battery.
There is not a single sound from the PC when I press the button, usually there would be a small sound and the cooler would start, but there is NOTHING at all, it seems completely dead except from the light of the battery and the USB connected deviced that power up.

Any more help is welcome
 
Thread starter Similar threads Forum Replies Date
R Laptop Tech Support 0
G Laptop Tech Support 1
mfenton27 Laptop Tech Support 4
C Laptop Tech Support 1
L Laptop Tech Support 2
B Laptop Tech Support 1
W Laptop Tech Support 5
D Laptop Tech Support 1
K Laptop Tech Support 1
J Laptop Tech Support 1
contactfina Laptop Tech Support 2
A Laptop Tech Support 5
B Laptop Tech Support 1
A Laptop Tech Support 1
B Laptop Tech Support 1
F Laptop Tech Support 1
P Laptop Tech Support 2
S Laptop Tech Support 1
V Laptop Tech Support 2
S Laptop Tech Support 3

ASK THE COMMUNITY