Question Trying the whole day to install win7 + make the ssd work with GPT file system:(

Nov 29, 2020
1
0
10
0
hi there, im pretty desperate currently, tried this for so many hours, but i just cant get it to work.

(i use a windows7 version 64x with skylake support)

i have a 128 and 64 gb ssd, both were gpt some time ago, im not fully sure but at some point i must have converted one to mbr (took me many hours).
i found my old 64gb ssd 2 days ago and it worked twice, i managed to install win7 proffesional on it and had gpt, the gpt was already the active partition style.

then i must have formated the 64gb one and it was no longer gpt but mbr now. i tried countless hours to use diskpart during the installation (f10+shift) which worked, at least, each time it says it is gpt (* at GPT in the command terminal).
after installing the win7, each time after im on the fresh desktop, it shows me 'MBR' in the partition tool of windows. my progam which needs gpt doesnt work and it drives me nuts:/..

i even tried to use linux mint twice, changed the partitionstyle to gpt and tried it. without success.

both of the ssds are just displayed as p3:<ssdName>, p4:<ssd brand name etc>, but without uefi in front of it. not sure what i should do.

i used pendrive tool universal usb to iso for creating the iso bootable usb drive. i also tried rufus and with gpt option enabled, but the uefi version of the stick crashes right after the progressbar is done.

i really thought about buying a new, bigger ssd, but i dont want to pay so much money again, and if the ssd becomes mbr again i cant help it:/

could someone help me?

oh, i think win8 worked, and it als was gpt by default on the mbr ssd, but as soon as i tried win7 on that ssd again, it switched to mbr again:(😪

i hope you guys can help me:/

 
Last edited:

AlHuneke

Prominent
Jul 7, 2020
372
36
540
39
I encountered a similar problem some time back and can feel your pain. Took a lot of fooling around to fix the problem. I ended up starting CMD running as admin and then used diskpart to completely erase all disk information ("Clean" as I recall). You may have to set up partitions with diskpart, but I don't recall. Sorry I can't give you all the steps. BTW, I also had to try several different Rufus options to get that to work.

I wonder why you are installing an OS that has been unsupported for a year. No security updates. You really need to be switching to Win10. The new media installation tool makes it easier.
 

AlHuneke

Prominent
Jul 7, 2020
372
36
540
39
I should have added that changing a disk between GPT and MBR can be done using the diskpart command CONVERT. Following is how I have fixed USB sticks after Rufus made them GPT. One of my other computers didn't like that. Maybe you can use some pieces to help you:

Clean a disk (hard drive or USB stick)

Type "Cmd" into the search box on left end of command bar and click on "Run as Administrator"

Type "Diskpart" at the command prompt. Spend a little time with Help to gain a basic understanding of the commands. Typing a wrong command can lead to complete loss of system partitions!

Enter "list disk" to determine the disk number of the disk of interest. Probably will never be disk 0!

Enter "select disk N" where N is the number of the disk of interest.

Enter "detail disk" to help confirm the proper disk is selected.

Enter "clean all" to clear all info from the disk. This will take a LONG time (could be many hours or even days!). You can leave off the "all" to not actually erase the disk data but clear the disk setup info which effectively makes any data unreachable. This option is very quick.

Enter "convert gpt or mbr" to make the disk type what you want. USB sticks should generally be MBR for general data storage. May need to be GPT to be bootable.

Enter "create partition primary"

Enter "format fs=fat32 quick" if USB data stick. Otherwise select the appropriate file system.

Enter "active" Not sure this is needed. Try it without first.

Enter "assign" Ditto

exit
 
Thread starter Similar threads Forum Replies Date
M Laptop General Discussion 2
P Laptop General Discussion 1
J Laptop General Discussion 3
Prabhu Mylsamy Laptop General Discussion 7
Mcstick333 Laptop General Discussion 1
H Laptop General Discussion 2
Varun_Sharma8054 Laptop General Discussion 0
Lutfij Laptop General Discussion 0
P Laptop General Discussion 1
A Laptop General Discussion 4
J Laptop General Discussion 3
J Laptop General Discussion 1
5 Laptop General Discussion 2
A Laptop General Discussion 1
D Laptop General Discussion 1
D Laptop General Discussion 3
J Laptop General Discussion 1
S Laptop General Discussion 4
P Laptop General Discussion 1
M Laptop General Discussion 8

ASK THE COMMUNITY