Ultrabook hangs at BIOS when SSD is detected.


Aug 5, 2015
Hello Tom's Hardware,

After two days of working on my Ultrabook, I am getting no where.
So, my friend who is a Korean exchange student broke his LG Tabbook Z160. I have a crappy 10 year old computer, so I asked if I could have it. When I say break, I saw it happen. It worked one class period, then the next when he booted it up. Everything was gone, just a BIOS was left. I figured he broke the SSD. So I went to replace the drive like normal, installed Windows 8.1, after disabling secure boot. Everything worked great, then I restarted. After that, the system hung at the LG loading screen (which I guess was POST?). After trial and error, the system would always hang at the LG screen, as long as an mSATA drive was present in the only port. I could attach an external harddrive or a bootable usb, and it would work, but only if no internal drive was present. This is quite strange. As far as manuals and drivers, I'm flying in the dark. Tech support ended ages ago, and the product is Korean, so not much shows up on Google for me.

Please help me. I'll do anything to get this working. I'll be happy to provide any information.


Things I've Tried:
Resetting BIOS settings
Installing Linux, which actually did work. I can't get it to work again though.
Hot plugging drives.