USB Root Hubs not showing in device manager

Razor88

Honorable
Oct 1, 2013
2
0
10,510
0
Hey guys

I have a Dell Inspiron 3521 (Windows 8.1), whose USB ports suddenly stopped working. The USB Root Hub showed a yellow exclamation mark next to it in device manager, so I tried uninstalling them and restarting the laptop to no avail. It now shows 3 Unknown devices and no USB Root Hubs.

I have tried installing the latest chipset drivers with no luck. Does anyone have any suggestions?
 
Hi,

Please do try to uninstall/reinstall that driver that has a problem. :)
- In Device Manager uninstall those 3 unknown drivers.
- Download install the Intel Chipset driver from Dell Support site.
- Here's the link: http://downloads.dell.com/FOLDER01692896M/1/Chipset_Driver_61V9W_WN_9.4.0.1026_A00.EXE
- Once the driver has installed reboot your laptop then check Device Manager again if it would be listed normally and will work.
- If these will not work do a System Restore, restore it back to an earlier date or time when you remember it was working fine.
- Lastly, doing a clean install would also resolve the issue.
 
Thread starter Similar threads Forum Replies Date
mimarcincin Laptop Tech Support 3
G Laptop Tech Support 5
Y Laptop Tech Support 1
J Laptop Tech Support 1
J Laptop Tech Support 2
S Laptop Tech Support 1
A Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 1
A Laptop Tech Support 1
K Laptop Tech Support 1
I Laptop Tech Support 3
fennie999 Laptop Tech Support 2
L Laptop Tech Support 1
K Laptop Tech Support 1
M Laptop Tech Support 7
W Laptop Tech Support 2
T Laptop Tech Support 1
J Laptop Tech Support 4
Y Laptop Tech Support 1
Similar threads
Question Disable faulty GPU that is not showing in Device Manager
Solved! "Plugged in, Not Charging" SCHOOL LAPTOP, SHOWING 3 BATTERYS?
Solved! asus webcam not showing in device manager
Solved! On device manager,there is only the wired connection showing ,no sign of wireless adapter
Sony vaio E series Not Work Dvd writer & Not show Device manager & Show device manager Unknown driver issue
Solved! Laptop fan speed increased and nvidia graphics not showing up in device manager
Solved! I recently installed windows 10 pro in my Acer pc. After installing that it did not show Intel(R)graphics in device manager.
In my pc's device manager there is no imaging devices, my pc's camera is not working, when i start the camera it shows connec
I have 2 graphics cards showing in device manager where it says they both work but when I open radeon settings it doesn't work
I have a amd radeon r2 graphics but it not showing to solve in my laptop s device manager
Nvidia gpu not showing in device manager
Touchpad doesn't work or show up in device manager
device manager didnt show up external hard disk
My lenovo laptop shows Iphone in device manager as being not migrated
Device not showing up
Device manager not showing nvidia graphic cards
670m Not Working or Showing Up in Device Manager
Toshiba Satellite disk drive doesn't show up, but device manager says everything is working fine
Nvidia card not showing in Device Manager, Gpu not detected.
I have a VAIO VPSSB18GG laptop. Device manager shows my BT mouse but it doesn't work. Just stopped suddenly. All drivers are i

ASK THE COMMUNITY

TRENDING THREADS