Vizio tv m470sl slow wireless internet if connection has security

biffenbob

Honorable
Nov 11, 2013
2
0
10,510
0
Tv: Vizio m470sl
Router: Linksys WRT160N

Using the Tv's built in speed test, without any wireless security I get about 2,000kb/s. When I add security be it WEP, WPA, WPA2 etc. The download rate drops to below 100, and makes things like netflix and pandora unusable. The router is running 802.11n like the tv recommends.

Any ideas?

Thanks
 

biffenbob

Honorable
Nov 11, 2013
2
0
10,510
0
I got it mostly fixed, in case anyone else ever has the issue here is how.

Wireless is WPA2 Personal, Encryption is AES.
Network mode is N only, radio band is standard 20 MHz. Standard channel is 5 - 2.432GHZ.

I live out in the country, so my router is the only one around, so I have no idea why changing the channels helps but it did. The tv still downloads faster when encrypted, but now with those settings it gets about 4,000kb/s encrypted, and almost 8,000kb/s when not.

Edit: I cannot see how to mark this thread as solved. So if a mod would mark it, or if someone could point out how, that would be great.
 
Thread starter Similar threads Forum Replies Date
winston89 Streaming Video & TVs 0
J Streaming Video & TVs 3
X Streaming Video & TVs 2
D Streaming Video & TVs 1
Bradagan1 Streaming Video & TVs 1
T Streaming Video & TVs 3
D Streaming Video & TVs 0
A Streaming Video & TVs 4
H Streaming Video & TVs 1
B Streaming Video & TVs 1
B Streaming Video & TVs 2
R Streaming Video & TVs 1
T Streaming Video & TVs 1
J Streaming Video & TVs 1
K Streaming Video & TVs 1
S Streaming Video & TVs 2
2 Streaming Video & TVs 2
W Streaming Video & TVs 3
F Streaming Video & TVs 1
C Streaming Video & TVs 1

ASK THE COMMUNITY

TRENDING THREADS