Weird headphone issue?

Slammed Tiger

Estimable
Nov 2, 2014
3
0
4,510
0
Recently my friend purchased headphones off Amazon. These are nice quality headphones, not very expensive but they work very well. At least they did on HIS PC. On my PC, however, they don't work as well. At first we had issues with my PC registering them as headphones. After that we had found out that the right ear would not play audio. So for about a week now I have been using them for left ear audio only. Just today, though, the right ear started working. It came on for about a minute then went off. It has been doing this for about half an hour at the point of writing this. So I want to know why it's doing this and how to make it so it can work consistently rather than only every now and then.

No, I have no idea how to get it to work. It just comes on when it feels like it. I am using VIA High Definition Audio for my audio, in case that is necessary. If it would be at all possible to install realtek (if realtek is better) over VIA then I would welcome this as a way of fixing my issues. Also, yes my headphones are plugged in correctly.


These are my headphones: http://www.amazon.com/VersionTech-Comfortable-Lighting-Headphone-Canelling/dp/B00PUMKFLC
 

Slammed Tiger

Estimable
Nov 2, 2014
3
0
4,510
0
I now have the latest drivers, my jack is working perfectly, and audio is streaming directly to my headphones with no issue. The issue I am having is that my right headphone will not work consistently. My sound card isn't the issue either as it works just as well.
 

Slammed Tiger

Estimable
Nov 2, 2014
3
0
4,510
0
Okay so I found out that my front panel jack is possibly broken. The back panel jack works perfectly and streams audio to both headsets fluidly and at a good volume, while the front panel only stream audio to the left ear. I solved my own problem.
 

ASK THE COMMUNITY

TRENDING THREADS