Question when i boot up my pc after changing ram, my monitor says that there's no signal, can someone help me??

Dec 10, 2020
9
0
10
0
I recently bought 32 GB of ram to replace my current 8GB, I've checked compatibility, and it fits perfectly, I've also checked ram capacity, and i have more than enough, thank you
 

mejustsayin

Proper
Oct 11, 2020
198
15
145
13
need the model number of the comuter and exactly what ram did you install? It is usually one of two things, wrong ram or not fully pushed into the slot.
 

mejustsayin

Proper
Oct 11, 2020
198
15
145
13
Thanks for the info...Now know where to start.

I will assume you purchased crucial recommended ram for your specific system? You really did not give all the info about the ram to verify you purchased the right ram if you did not get what crucial recommends.

So, did you try them one at a time? did you try them in different slots. Did you push them until you heard a click when installing?
 
Dec 10, 2020
9
0
10
0
Thanks for the info...Now know where to start.

I will assume you purchased crucial recommended ram for your specific system? You really did not give all the info about the ram to verify you purchased the right ram if you did not get what crucial recommends.

So, did you try them one at a time? did you try them in different slots. Did you push them until you heard a click when installing?
I will try to get you the information, can you please tell me everything you need to know?
I have tried both ram sticks separately, in different slots, both together, and every possible combination. I pushed them until I heard two click, one on each side, but one thing I have noted, was that when I went in my bios earlier today, in the overclock part, I attempted to change the DRAM things, i got a few options, like DDR4 2400 CL16, but my new ram is DDR4 2400 CL17. I then spent a while googling things, and found people suggesting that I find the XMP, but my pc says it doesn't support it..
 

mejustsayin

Proper
Oct 11, 2020
198
15
145
13
maybe check out toms hardware forum and see if they can help. they are related to this site

 
Dec 10, 2020
9
0
10
0
I have bought 32 gb of crucial ram (2x16)
DDR4 2400 CL17, and when I put it in my pc, my pc bots up, but then my monitor doesn't get a signal. I then went into my bios, and tried to change the RAM, in the OC part, i didn't get the option for DDR4 2400 CL17, I only got from CL1-CL16.
Why is this?
Will I be able to use this ram on my pc or do I have to send it back?
(XMP is not supported)
Thank you for your time
 
Thread starter Similar threads Forum Replies Date
bjroxx3 Laptop General Discussion 2
betawastaken Laptop General Discussion 1
R Laptop General Discussion 2
Gamer boii Laptop General Discussion 0
Gregoryan Laptop General Discussion 7
R Laptop General Discussion 0
Liamdacs Laptop General Discussion 1
FragaZ Laptop General Discussion 2
E.D. Laptop General Discussion 2
Z Laptop General Discussion 5
mozn Laptop General Discussion 2
I Laptop General Discussion 1
A Laptop General Discussion 9
K Laptop General Discussion 9
RolandM Laptop General Discussion 4
W Laptop General Discussion 3
N Laptop General Discussion 2
P Laptop General Discussion 1
S Laptop General Discussion 1
G Laptop General Discussion 1

ASK THE COMMUNITY