Why doesnt GTA 5 run on my laptop anymore

Ahmed23

Estimable
Apr 18, 2015
15
0
4,570
Hello there, I used to be able to play gta 5 on my laptop with no lag (DELL Inspiron 15r 5537) which is: i7 4500u @ 1.8Ghz up to 2.4Ghz, 8GB ram, Direct X 11,1TB hdd, Windows 8. I was playing one night then my dad took my charger away (grounded). 1 month passed and he didnt give it back so I bought a generic one from memory express . I plugged it in and started my laptop. I started gta 5 and for some reason it started lagging and then my charcter had some weird pixely, transparent look( except for his clothes). could this be bcuz of the power cord getting replaced with a diff one and also whenever i play any sort of audio the speakers make a static noise which sucks. plz tell me what the reason is and if it is indeed the power cord
 

Im Spartacus

Estimable
Mar 25, 2015
339
0
5,210
You need to make sure the lead you bought is a suitable replacement for your laptop. Sounds like its picking up interference from the capacitors not filtering sufficiently in the lead power brick this is causing static on the audio and interfering with graphics.

The way to diagnose this is when you plug the lead out if it stops when on battery your lead is at fault. Make up with your dad and get your lead back
 

Ahmed23

Estimable
Apr 18, 2015
15
0
4,570
Hi Im Spartacus, I tried what you said about checking if the lead is fault and it is not i played audio without the lead being plugged in and it still made the noises. I also have made it with my dad (took a while) and he is giving it back to me on Sunday.

And could the noises be a hardware problem if its not the lead doing it. Also about GTA 5 is it hardware prroblem doing the transparent pixely thing because it did the same thing unplugged..??
 

Im Spartacus

Estimable
Mar 25, 2015
339
0
5,210
Next thing does this happen in other games if yes one of two things first can you do a system restore back to when GTA was working fine. By doing a system restore not a factory reset a system restore.
Two re-install your graphics driver I take it's using the Intel® HD Graphics 4400, on the i7 as i'm not familiar with your laptop.
If it only happens in GTA5 try re-installing that game.
It might just be a fluke this all occurred when you got a new lead.
One more thing have you tried the lead on its own no battery plugged in? But try using the correct original Dell lead. Maybe the battery's at fault?
 

Ahmed23

Estimable
Apr 18, 2015
15
0
4,570
Uhm, lol uhhh.... I actually delete system restores to clear up memory.. And yes most likely its a fluke with the lead. Im going to try tomorrow with the original dell lead and hopefully it all goes back to normal -if not i will take my laptop to geek squad and try to get it fixed. I also will try re installing the graphics driver which is intel HD graphics 4400
 

Im Spartacus

Estimable
Mar 25, 2015
339
0
5,210
Good luck
One more thing to try go to control panel then power options click on high performance power plan, select advanced settings select cpu state, change both minimum an maximum settings to 99%.
I'm assuming you're using high performance power plan reboot does it still happen.
 

Ahmed23

Estimable
Apr 18, 2015
15
0
4,570
So I did what you said but do i set both unplugged and on battery settings to 99% for minimum and maximum? Yes i am using high preformance plan btw. Im going to go to geek squad tomorrow like i said before and hopefully they fix it. I also got my charger back and drained all the battery out and then started charging with the dell lead and the static noises are still there when i play audio. and how would i reinstall my graphics driver.
 

Im Spartacus

Estimable
Mar 25, 2015
339
0
5,210
If you never done this before might be best to let geek squad do it.
But basically you type device manager into start menu select it find then select display adapters disable your current one followed by scan for hardware changes in the menu should find your driver or select from link select correct driver from list and reboot the laptop.
Here is a link to the intel web site for 4400 graphics driver
https://downloadcenter.intel.com/search?keyword=4th+Generation+Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+HD+Graphics+4400

If you run into more problems restart in safe mode and enable your original driver and disable the other to get it back and followed by reboot.
 

Ahmed23

Estimable
Apr 18, 2015
15
0
4,570
so i went to geek squad and they said they might turn my laptop to its original state when i got it (hardware not physical) and might fix the fan vent because it cracked and apparently the warranty "doesnt cover physical damage" when it clearly says wear and tear covered and any type of physical damage. It will take 2 weeks for them to get it back to me. the audio is working fine now because i am using the original dell lead. but gta 5 i still pixely and transparent but doesnt lag anymore. I just want my laptop to come to its original state before i got it taken away. Also how did you know the thing about the capacitor not filtering sufficently did you do some computer related jobs or something??
 

Im Spartacus

Estimable
Mar 25, 2015
339
0
5,210
I'm 53 years old i have played with many things in my time 1980 CB radios, computers many audio and video related items. I've no qualifications in any of these subjects just gained self taught knowledge I understand many things but have still many things to learn.
I know by helping others I can learn more.
I have gathered you are young and in time if you adopt my attitude you will learn a lot by helping others when you can. The world wide web it a great source to find things out and learn more? You want to gain knowledge fast. Do what I do ask the question in the correct way in a search engine the information will be out there. As for the capacitor acting like a filter I bought an amp cheap at a boot sale in the 80s when i got it home it all worked but the audio sounded distorted. So I asked the advice of someone in the know who then kindly placed in circuit an additional capacitor to filter the noise that is how i Knew. I recently replaced a failed capacitor in an PVR they don't just filter sound they filter video or graphics a blown capacitor can also cause a dead circuit but something would have caused the capacitor to fail..
Now I advise you not to just try changing capacitors to see if it will fix things. Capacitors come in low voltage and high voltages.
As they act like batteries capacitors store electricity if you try to remove a capacitor with a high enough voltage that has not been discharged you could kill yourself. I was shown how to do it by a trained electrician but even i would not touch a high voltage capacitor or any type of high voltage circuit. If you don't know what your doing electrical fires can start even in low voltage circuits.
PS.. Don't go falling out with your dad? Look what happened be wise be careful life will be easier.
 

Ahmed23

Estimable
Apr 18, 2015
15
0
4,570
I see.. thanks for telling me your story. and by any chance do you know the reason for the pixely transparent character look. I still haven't fixed it.. any more ideas?? And what does dont go falling out with your dad mean??
 

Im Spartacus

Estimable
Mar 25, 2015
339
0
5,210
3 or 4 Possibles to be eliminated by trial the incorrect lead could of caused hardware failure in a shop it would be easy to do this first would be swap in order the ram then cpu followed by motherboard problem but My first guess is you lead caused software corruption to you hard drive as it was reading and writing files to one of the many shared files on the hard disk. This is why the shop is doing this option first. They can run some software to test the other things.
Here is a link see physical defects the wrong lead can effect the working of the hard drive.
http://www.datarecovery.com.sg/data_recovery/data_corruption.htm
 

Ahmed23

Estimable
Apr 18, 2015
15
0
4,570
so if it is hardware failure they can fix it right?? and hopefully when i get it back its fixed. I just want to be able to play gta 5 again normally. i guess i should have been a good kid and waited for me to get ungrounded :( . if it isnt fixed when i get it back i will go to geek squad and tell them about it. I only told them about the audio and the fan vent being broken.

 

TRENDING THREADS