Question Windows stuck at installation on laptop

Goran Petric

Estimable
Jul 27, 2014
10
0
4,560
0
This is ages old problems, was reading all day thro all the posts on the interwebz, but no real solution for laptops (lots of people fixed it by removing cd drives or extra hard drives, i have none of this on laptop)
I took friends Toshiba Sattelite laptop for 'repair', its bit older model with amd a4 apu, it had win8 installed and filled with <<Edited>>, it was barely running and couldnt even run a program on it, so i tried to do the thing that i did 100 times allready, put fresh windows installation with help of my friend rufus&usb. It installs normally, then restarts and gets stuck at ''starting windows'' screen. Tried both win7&10, does the same thing. Now im currently draining the battery with bright bios screen, to try and ''reset'' cmos, because i dont feel like opening it up and ''removing'' integrated battery. Has the be all & and all solution for this problem been found allready? Am i missing something? I tried tinkering with all the bios settings but doesnt help, reinstalled windows numerous times just for the hell of it, gets stuck every time, even in safe mode ofc, gets stuck at classpnp.sys
 
Last edited by a moderator:

NerdyComputerGuy

Honorable
Nov 19, 2013
113
0
10,710
33
What was the original problem with the laptop when you received it from your friend?

I've ran into similar problems on some laptops that wouldn't boot, and stalled on the installation screen, you say that it passes installation but on boot it get's stuck at 'starting windows', is the new windows installation running Windows 7, 8, 10 or other?

I'm going to take a wild guess but it could be a problem with the hard drive, please update me on the above and I will see what you can do to fix the problem.
 

Goran Petric

Estimable
Jul 27, 2014
10
0
4,560
0
Originally it was super slow and filled with viruses, installed ableton and it wouldn't run, some strange error, decided the best thing is to get it off that broken win8 and install fresh win 7. Tried both win 7 / 10, no avail, put new ssd in, instalation of win is super slow, takes probably 2 days, and once it even errored out. Put old toshiba hdd in naother pc and it booted into win fine, was asking me for my username to complete setup. Than reinstalled win there, put it back in laptop, and the same thing, it stucks at classpnp.sys. I'm totally out of ideas....

The problem is, the damn thing was ''working'' before... i can't just hand it back to him in this broken state, i have been at this for 2 days now, i need to figure this out... even tried shift+F10 with cmd switched to performance mode durring installation... doesnt help


Inserted ssd, now i set boot to IDE, inserted win7 usb that mbr instead of gpt... now cmd powercfg is not even reckognized....installation is at 2% .... and it errored out on that new SSD ''windows cannot install rew file doesnt exisdt bla bla bla 0x80070002
 

Goran Petric

Estimable
Jul 27, 2014
10
0
4,560
0
Its done.. it works, but its random, it shouldnt. I touched all connections, reinserted ram, than put its original hdd that i installed windows on another pc and gone thro the procedure fully, put it back in laptop and this time it worked, but 3 attemps before from other hdd's that had win installed didnt work. .... booted into win and all.... i think in bios im not on uefi, but in IDE, im afraid to even go to bios again...,. ill install all the crap and hand this hot piece of potato called toshiba back to its owner. <<Inappropriate language removed by moderator>> Long live desktop pc master race (i have like 10 pc's in my house, building and selling and stuff, but mosatly buidling and sitting there :p )
 
Last edited by a moderator:

Goran Petric

Estimable
Jul 27, 2014
10
0
4,560
0
Okay.... now that i sleeped overnight and i'm free of stress, let me explain what i did so it might help someone in the future. Perhaps the thing was the ram module that i re-inserted. First i put it in another slot, black screen no picture, than i put it in original spot, along with its original toshiba 500gb hdd on which i installed windows on another pc (went thro whole procedure got to desktop and than shut it down) It booted it, and i was able to do my thing. Bios boot was set to ide (compatibility) instead of UEFI, and the usb win7 instalation was not GBT but set on MBR via rufus. I played around with both types of instalation disks but it wouldnt work before, it would hang every time. It would either error out saying insert media, proper boot device, pxe-mof, pxe-e61 check cable...or if i menage to get pass that it would hang at starting windows/classpnp.sys.... Also if i put new hdd/ssd in laptop and tired to install win from there, it would error out and was so slow that it would be days before installation is complete....Also did pwcfg to high performance on pervious attempts, dunno if laptop remembered those commands after reboot, but i will mention it because i did that too.

This crap stressed me. The owner of laptop was a guy sitting next to me on ableton workshop school, and his laptop was miserable, couldnt even run the program after it took 1h just to install it, so i say hey gimme dat, come pick it up at my place tomorrow and it will be all fresh win working like a charm, for free, because i am smart like that.

And i almost bricked it instead -_- Never touching Toshiba laptop again.
 
Thread starter Similar threads Forum Replies Date
agrydon Laptop Tech Support 2
SnackinMcCracken Laptop Tech Support 1
J Laptop Tech Support 0
B Laptop Tech Support 1
O Laptop Tech Support 1
M Laptop Tech Support 1
L Laptop Tech Support 1
S Laptop Tech Support 3
A Laptop Tech Support 1
A Laptop Tech Support 11
K Laptop Tech Support 3
L Laptop Tech Support 1
S Laptop Tech Support 6
A Laptop Tech Support 2
N Laptop Tech Support 1
M Laptop Tech Support 8
K Laptop Tech Support 1
P Laptop Tech Support 13
S Laptop Tech Support 1
H Laptop Tech Support 2

Similar threads


ASK THE COMMUNITY