5.1 Not Working Except in Testing

Jhact

Honorable
Aug 10, 2013
17
0
10,560
0
My Logitech Z506's haven't been playing out of the back speakers. When I test them in Razer Surround Pro or in Windows they work fine, but in action they aren't working. Even in Team Fortress 2 I have it set to 5.1 Speakers and they still don't work. Is 5.1 just not supported in much stuff or why is it doing this?
 

bfloyd

Estimable
Jan 7, 2015
1
0
4,520
1

5.1 is supported on everything except old dvd's and games. How is your signal flow set up? and what are you setting setup on ur tv? check out http://beetsbox.com/home-theater-set-up-and-wiring
its a quick signal flow and set up guide
 

bfloyd

Estimable
Jan 7, 2015
1
0
4,520
1

5.1 is supported on everything except old dvd's and games. How is your signal flow set up? and what are you setting setup on ur tv? check out http://beetsbox.com/home-theater-set-up-and-wiring
its a quick signal flow and set up guide
 

Jhact

Honorable
Aug 10, 2013
17
0
10,560
0
Okay, since I've had trouble with Razer Synapse with my keyboard before, I thought that may be it. Sure enough, I disabled Razer Surround Pro and my speakers work fine. I love my Blackwidow Ultimate and Deathadder, but Razer needs to fix their software.

I greatly appreciate you trying to help though! Thanks!
 
Thread starter Similar threads Forum Replies Date
A Audio 2
C Audio 17
E Audio 2
A Audio 4
C Audio 1
X Audio 2
A Audio 1
C Audio 2
J Audio 1
G Audio 5
H Audio 3
A Audio 3
E Audio 2
M Audio 3
D Audio 3
S Audio 1
C Audio 6
Headzyy Audio 5
I Audio 9
S Audio 1

ASK THE COMMUNITY