Acer Aspire S3-391 BIOS Recovery / BIOS Password Remove / No Bootable Device issue

arifr

Honorable
Sep 20, 2013
1
0
10,510
0
hi,
i am having big issue with my Acer Aspire Ultra-thin book S3-391-6046 laptop. i recently updated its BIOS from 2.0x to 2.17 version which showed successful, it rebooted and came online fine. i re-ran the BIOS updater again by mistake, ideally it should exist or give me a message that BIOS is already latest version or no update required, instead it continued, rebooted Laptop and started block update. however this time after performing the activity, when Laptop was rebooted, it showed "no boot device" and kept showing this even-though there are two bootable USB flash drives connected, one is having Hiren's boot-cd and the other one Windows 8. with the same USB drives, it was previously booting, and in fact i did Windows 8 installation on this Laptop using the one bootable USB drive having Windows 8 installer.

i tried using boot-device selection option during BIOS start-up by pressing F12, it shows the same message "no bootable device". i bought this Laptop quite some time back from eBay and it had a password set in BIOS which didn't bother me so far because of the Laptop was booting properly. now i can't have the password anymore. i wanted to go in BIOS by pressing F2 and see what are the disk-drives its detecting, and also choose what to boot-up from. as i am unable to go in, i tried to remove BIOS password from CMOS. i opened the back-cover and tried few ways that i found by Google, though the methods were specific to other models which are older and not anything specific to my model or any Acer Ultra-thin book, eventually i didn't succeed. the method i found in below:

http://www.manualslib.com/manual/483179/Acer-Aspire-S3-391.html?page=165#manual

i suspect the issue is with the BIOS which may have got corrupted. the other way i tried to recover the BIOS to the default state what may be saved inside the Motherboard. i tried the generic way that i found in Google, again this time too the method was not specific to my model, but it appeared to me that the method would work. detail method i found in following threads:

http://forum.notebookreview.com/acer/284686-aspire-5315-bios-recovery-using-usb-thumbdrive.html

http://forum.notebookreview.com/sager-clevo/326954-case-you-kill-your-phoenix-bios-bios-recovery-methods.html

now, with these options, it didn't work. now i am not sure what else i should do before going to professional service-shop which would cost a lot. if anyone can advise a solution, i will be happy to give it a shot.

let me know if you have any question. Laptop is still continuing showing "no boot deice" message. Laptop has a 320 GB HDD, 20 GB SSD.

thanks.
 

ngrego

Distinguished
Jan 25, 2012
37
0
18,590
3
Flashing your BIOS to the version already installed shouldn't cause any harm to your laptop other than resetting any settings you have made.
You could try downloading a copy of the previously installed version and downgrade to the older version.
Otherwise you could try to clear your CMOS either by using the jumper (manually) or setting to defaults from BIOS setup.
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 3
S Laptop Tech Support 1
S Laptop Tech Support 2
J Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 5
J Laptop Tech Support 1
A Laptop Tech Support 1
O Laptop Tech Support 1
H Laptop Tech Support 1
V Laptop Tech Support 10
CupTheYoutuber Laptop Tech Support 28
T Laptop Tech Support 3
H Laptop Tech Support 9
A Laptop Tech Support 3
K Laptop Tech Support 4
J Laptop Tech Support 3
B Laptop Tech Support 4
S Laptop Tech Support 1
D Laptop Tech Support 1

ASK THE COMMUNITY