Acer E1-510-4457 Win 8.1 x 64 - Does Not Detect Wireless


Oct 26, 2016
Acer E1-510-4457 Win 8.1 x 64 – No wireless Connection available.
Laptop = Acer E1-510-4457
OS = Win 8.1 x 64
Cell Phone = Blackberry Classic Q 20
Requesting assistance how to connect Laptop to wireless network (cell phone wifi hotspot). I live in remote rural area, only internet access is wireless via cell phone.

Method to turn on Wifi on this specific Acer -is Fn + F3 --- To confirm wireless switch is on, a light will come on left side front panel where there are 4 lights, the 4th right light is WiFi- - irregardless of how many times this combo is done, WiFi Light never turns on.

I have spent month researching online, ACER community forums, Win 8.1 forums for wireless etc. …. Apparently this is common problem with this laptop model. The following suggestions helped “solve” some Acer users…. I have attempted but have not been successful. >>>>>> HELP <<<<<<<

1. Recovery to previous windows updates…unsuccessful.

2. Click on Network connections, lower right corner, click on wireless connection.
Message says "No connections are available"

Clicked on Troubleshooting-- result -- A Network cable is not properly plugged in or may be broken.".......... connected USB phone cord to laptop, Internet Tethering option, mobile hotspot option did not work.
1) Click on start --> In search bar, type ncpa.cpl and press Enter.
"Network Connections" will be opened.
2) Right-click on your "Wireless Network Adapter" --> Properties -->
Select "Internet Protocol Version(TCP/IPv4) --> Click on "Properties" buttion --> Make sure "Obtain an IP address automatically" is selected --> Click on OK

There isn’t a “Wireless Network Adapter” listed. The 2 options listed are Bluetooth Network Connection and Ethernet.

- Go to "Device Manager" and click in the little arrow to the left of "Network Adapters" to open all the devices.
- Right Click on "Qualcomm Atheros" and click in "Properties"
- Click on the "Resources" tab and click on "Wireless Mode"
- Change "Value" to "01-11b" (it was set in "12-11a/b/g/n/ab")
- Click "ok" and make sure you are connected to your wifi network.

Went to “Device Manager” and 2 items have yellow exclamation marks.
i) Network Adapters
Qualcomm Atheros AR956x wireless Network Adapter
ii) Other devices
PCI Device
Right clicked on “Qualcomm Atheros” – “properties”…..No Wireless Mode option appears.
Statement reads : This device isn’t using any resources because it has a problem.

Under “General Tab” – Device status: Windows cannot verify the digital signature for the drivers required for this device….. Code 52.

Under “Driver tab” – current driver version installed is
Went to Qualcomm Atheros & (on friend’s laptop via USB thumb drive) downloaded the latest driver update for win 8.1 x 64 which is version
Copied zip folder to Acer laptop – My PC; Drive C; Windows; System 32; Drivers folder.
Went back to Device Manager – Qualcomm Atheros Adapter- “properties” – update driver
Restart – Device Manager-Qualcomm Adapter “properties”-
Result – new version did not update.

Start > R-clicked on computer > Clicked on Manage > Hightlight "Services and Applications" > Double Click "Services and Applications" > Click on "Services" > Scroll to the bottom and find "WLAN AutoConfig" and make sure it is set to Automatic.

Problem: WLAN auto config is set for automatic, no change was ever made here.


Another possible solution: It works after installing Acer Launch Manager

Apparently there isn’t Acer Launch Manager download for Win 8.1 x 64


Researched Fn + F3 shortcut troubleshooting… no success.

Any input is welcomed, please help, need laptop for work.
Thank you

Will it allow you to connect via Ethernet cord connection? If you can try (I know sometimes that isn't possible, due to the modem/routers setup.)

Also, if you can (I would borrow one from someone rather than purchasing) See if an external wireless card will work for you. One that plugs into the USB port. If this works, then I would lean towards your laptops wireless is failing or failed and is in need of replacing.


Nov 19, 2016