Acer e5 572g won't start after dis/reassemble

Tsveteli

Prominent
Jun 18, 2017
2
0
510
0
My Acer e5 572g was running very hot lately and was throttling so I decided to clean the fan and the heat sink.

After reassembly the laptop does not start anymore - the led light flashes for 3-4 seconds, but the fan and hard drive don't start spinning.

I did not reapply thermal paste, but that shouldn't cause to no start I believe.

What could be the problem?
 

zer0c007

Notable
Jun 10, 2017
108
1
910
52
Try removing battery and charger and press and hold power button for 20 seconds then reattach battery and charger and power on. Not reapplying thermal paste isnt good idea, I'd do that and check adapter port is damaged.
 

zer0c007

Notable
Jun 10, 2017
108
1
910
52
Try removing battery and charger and press and hold power button for 20 seconds then reattach battery and charger and power on. Not reapplying thermal paste isnt good idea, I'd do that and check adapter port is damaged.
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 0
celassad Laptop Tech Support 1
tifa03 Laptop Tech Support 7
ClareJohnston Laptop Tech Support 1
N Laptop Tech Support 15
Rishabsg Laptop Tech Support 5
Tyrrella Laptop Tech Support 1
Kushal Shah Laptop Tech Support 3
S Laptop Tech Support 4
So.Sona Laptop Tech Support 7
N Laptop Tech Support 1
evilgoobur Laptop Tech Support 3
S Laptop Tech Support 2
G Laptop Tech Support 8
S Laptop Tech Support 4
Zkneedhelp Laptop Tech Support 2
B Laptop Tech Support 8
H Laptop Tech Support 1
Thaboss6 Laptop Tech Support 1
Spacebit Laptop Tech Support 1

ASK THE COMMUNITY