ASUS K55VD doesn't starts

skadoosh

Honorable
Oct 2, 2013
1
0
10,510
0
I have an ASUS K55VD. Recently I turned it off by holding the power button. Now when I starts the laptop nothing appears on the screen, CPU fan runs, power led is on, HDD led doesn't flashes.
I have already tried removing the battery and connecting to the wall, same problem.
Is there anything i can do.
 

dogla

Honorable
Apr 2, 2013
5
0
10,510
0
Hi, had similar problem. Turned out the mobo went bad. Might be same thing with yours. Now I replaced mobo already and laptop starts up fine, everything works ok, with external monitor, not with it's own screen.....that's the issue I'm having, but at least it runs ok.
 

roberto forcen

Estimable
Jul 22, 2014
1
0
4,510
0

did you change a bios parameter before failure?
this seems to be a common problem in asus laptops
 

lkap2

Estimable
Aug 31, 2014
1
0
4,510
0


I had the same problem, and I did change the boot option to Realtek. How do I fix this?
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 2
G Laptop Tech Support 8
S Laptop Tech Support 4
Zkneedhelp Laptop Tech Support 2
B Laptop Tech Support 8
H Laptop Tech Support 1
Thaboss6 Laptop Tech Support 1
P Laptop Tech Support 3
H Laptop Tech Support 2
J Laptop Tech Support 1
V Laptop Tech Support 2
R Laptop Tech Support 2
C Laptop Tech Support 7
D Laptop Tech Support 2
E Laptop Tech Support 2
S Laptop Tech Support 1
D Laptop Tech Support 1
M Laptop Tech Support 2
T Laptop Tech Support 5
A Laptop Tech Support 1

ASK THE COMMUNITY