Asus laptop won't turn on

Kems

Estimable
Oct 19, 2014
1
0
4,510
My asus laptop, model x42jy will not turn on. The power button flashes for 3-4 seconds fan & cd driver also make sound but seems to do nothing, not turning on.
When I plug in the charger, the green light under the battery comes on .
also i tried plug out charger & battery pressed power button for 30 seconds nothing happens
It's 3 year old. same problem occurs 3-4 times in a year after trying its solved. bt this time i m helpless nothing works every possible trick available on google i tried.please help me.
 

ivibre

Honorable
Aug 1, 2013
5
0
10,510
I wrote a reply but it didn't attach so in case it duplicates, I'll repeat in brief with the addition: and want to reply to you as well. I tried this solution also. I removed the battery, took off the back, removed the plug to the BIOS and waited (24 hours) until the next day to plug it back in thinking that would release any static build up if there were a capacitor or other thing I'm uneducated about but my BIOS didn't reset, hence the reason I wrote I was advised to replace the BIOS. I'd appreciate any more information you might have which would set me into a forward motion on this issue. Great post, thank you in advance. vii dii

I purchased new ASUS K50ij. Preinstalled W7, upgraded W8, W8.1, W8.1Pro. Got window "upgrade BIOS" so wrote ASUS asking for instruction. Received incorrect BIOS version. Black screen, blinking lights, seemingly operational CD, no USB, no keyboard (alternate keyboard not operational either nor USB or SD works). Advised to replace BIOS chip ($30?) on fixed income so remains bricked. ANY links, further suggestions please forward. Am following post now and appreciate greatly, remaining hopeful. vii dii
 

ivibre

Honorable
Aug 1, 2013
5
0
10,510
I purchased a new ASUS K50ij a few years ago. Something went amiss when they promoted an innacurate BIOS update which I obtained installation instructions BEFORE attempting to do so myself. I had received a window "update your BIOS". I had Win 7 preinstalled and upgraded to 8 then 8.1 then 8.1 Pro. Something went terribly wrong and when I turn it on, the lights blink, it appears the CD is functioning, no USB's and black screen. No keyboard and tried bluetooth and wired keyboard as well. I have no solution other than to replace the BIOS chip ($30ish?). On fixed income, the laptop (a sweet one with big screen, light weight - perfect for me) is bricked. I'm not suggesting this is your issue but would seem suggestive that any OTA updates or inaccurate updates might possibly be a culprit. I am [ticking] following this message for a couple reasons and perhaps we might solve the issue.
 

TRENDING THREADS