ASUS T100T not working after digitizer screen replacement

rizz23

Estimable
Aug 25, 2015
1
0
4,510
0
Hi everyone,
I hope you can help me because this thing is driving me nuts!

I have an Asus T100T transformer and I cracked (I sat on it) the screen, which is also a touchscreen. After that, I was still able to use the laptop, but the touch was gone on half of the screen.

So I ordered a new digitizer screen (as of http://www.amazon.com/Asus-Touch-Screen-Digitizer-Glass/dp/B00LP5CD68) and replaced the original following step by step the instructions here: https://www.youtube.com/watch?v=IBo8QwfmYSM

... But after powering the laptob back ok, I get a black screen. Or let's say blue screen, because the pc does power on, but nothing appears on the screen.

I checked all the connectors and tried replacing again the scrren with a third replacement one, but still the same black screen... What could have possibly gone wrong?
 
Thread starter Similar threads Forum Replies Date
Jirky Laptop Tech Support 0
T Laptop Tech Support 0
Cybertech119 Laptop Tech Support 1
P Laptop Tech Support 5
Suplink Laptop Tech Support 0
A Laptop Tech Support 0
MonkeyZki Laptop Tech Support 0
Mannicxils Laptop Tech Support 13
K Laptop Tech Support 0
E Laptop Tech Support 1
Rebria Laptop Tech Support 1
A Laptop Tech Support 0
F Laptop Tech Support 1
Isaiah90 Laptop Tech Support 0
K Laptop Tech Support 7
K Laptop Tech Support 1
SirDeafCheese Laptop Tech Support 3
R Laptop Tech Support 1
R Laptop Tech Support 0
N Laptop Tech Support 1

ASK THE COMMUNITY