Asus X550L not working period

Z3chyd

Commendable
Mar 10, 2016
2
0
1,510
0
I have an Asus x550l laptop that doesn't work. It worked when I replaced the dead battery with a fresh one off Amazon, and it said "plugged in charging" and showed an amber charging light, but was steadily losing battery percentage. I replaced the charger as well even though the original works fine just to be sure. I also replaced the charging port as well as I've heard they can become faulty, no dice. When plugged in now there's no lights, no attempts to turn on, with battery in or out. I've tried the "hard reset" removing the battery and holding the power button, no difference. I don't know if it makes a difference but it won't run off straight a/c power with the battery removed too. Please help it's a good laptop when it's actually on and I'm not wanting to give up the 1tb/16 gig ram lol
 

Z3chyd

Commendable
Mar 10, 2016
2
0
1,510
0
It's not the replacement battery because it did the same thing with the original name brand Asus battery. "Plugged in charging" but just running off battery power until it shuts off
 
Thread starter Similar threads Forum Replies Date
catrose Laptop Tech Support 0
jubitu8 Laptop Tech Support 0
B Laptop Tech Support 1
M Laptop Tech Support 0
3 Laptop Tech Support 1
powerman4u Laptop Tech Support 1
H Laptop Tech Support 6
Timewalker Laptop Tech Support 1
LeoLuca Laptop Tech Support 3
Q Laptop Tech Support 0
M Laptop Tech Support 0
S Laptop Tech Support 0
A Laptop Tech Support 1
M Laptop Tech Support 0
Xandersuys Laptop Tech Support 3
I Laptop Tech Support 4
D Laptop Tech Support 5
B Laptop Tech Support 1
T Laptop Tech Support 1
R Laptop Tech Support 1

ASK THE COMMUNITY