ASUS XONAR STX II 7.1 - No Sound

xavatarhax

Prominent
Oct 1, 2017
4
0
510
0
So, I've just put together a bunch of components I bought. Started up the computer, activated Windows 10 Pro and now I'm trying to get all my components to work and get the software running properly.

Mainboard: Asus ROG Crosshair VI Hero
CPU: AMD Ryzen7 1700 (8x 3.00GHz, plan to overclock to 3.8 - 4.1)
GPU: Nvidia Geforce GTX 1080TI 12GB iChill X4
Sound Card: Asus Xonar STX II 7.1
RAM: 2x 8 GB DDR4-3200 G-Skill TridentZ
Storage: 500GB M.2 SSD Samsung Evo 960 + 2 TB HDD WD Blue
Headset: beyerdynamic MMX300 Gen2
Keyboard: Corsair K95 RGB
Mouse: Corsair Scimitar Pro

After installing Windows, everything seemed to be working fine, until I plugged in my Headset. There is literally no audio output being received from the sound card. If I plug it into the onboard sound card, it does output some sound, but it's kind of weird. As if it's trying to output surround sound, but it's not working properly on the stereo headset.

I tried uninstalling and reinstalling the driver multiple times, using the unified driver right now. I have the molex cable connected to the card, it is definitely receiving power. The hardware seems to be working just fine. The only thing that could be broken are the output jacks.

My guess is that the issue lies within the software of the headset or the sound card. I'm not sure if I even have everything in the Bios set up correctly.

I changed the audio settings in Windows and tried turning off the onboard sound card in the Bios, but that still did not fix the issue.

I'd appreciate it if you guys could help me out with this.
 

anort3

Distinguished
Moderator
Is the sound card selected as the default audio device in Windows? I have an original STX and I don't install the onboard audio drivers and have the onboard disabled in the BIOS. They just cause conflicts. Also by default Nvidia will try to install their HD audio driver. Best way around that is to do a custom install every driver update so you can unselect it. If the Nvidia HD audio drivers are installed then uninstall them.

https://www.ghacks.net/2017/06/30/install-only-the-driver-for-nvidia-graphics-cards/

When you click on the volume icon in the system tray it should show the STX as the audio device.

Edit: Also make sure you have the correct out selected in the sound card's control panel.

 

anort3

Distinguished
Moderator
Is the sound card selected as the default audio device in Windows? I have an original STX and I don't install the onboard audio drivers and have the onboard disabled in the BIOS. They just cause conflicts. Also by default Nvidia will try to install their HD audio driver. Best way around that is to do a custom install every driver update so you can unselect it. If the Nvidia HD audio drivers are installed then uninstall them.

https://www.ghacks.net/2017/06/30/install-only-the-driver-for-nvidia-graphics-cards/

When you click on the volume icon in the system tray it should show the STX as the audio device.

Edit: Also make sure you have the correct out selected in the sound card's control panel.

 

xavatarhax

Prominent
Oct 1, 2017
4
0
510
0
So, I just uninstalled the Nvidia HD Audio Driver, disabled the onboard sound card, and reinstalled the UNI driver.

My current settings are like this:



Although the sound card seems to be outputting sound, neither of my headsets seem to pick up any.
Both the headsets are working fine when using the onboard sound, and on my old computer.
--------------------------------------------------------------------------------------------------------------------------------------------------
Edit: So now I did all those steps again, deactivated the onboard sound card completely, and changed around the settings a bit and it works.

Current settings:



Thanks a lot for your help, mate!
 

devmahajan

Prominent
Dec 20, 2017
1
0
510
0
For all Xonars: Connect sound card. Leave cabinet open and boot to desktop. Install drivers. Then pull out Molex power cord from sound card and plug it back in. Sound card works flawlessly.
 
Thread starter Similar threads Forum Replies Date
Chinu8763 Audio 6
A Audio 2
J Audio 7
J Audio 2
Y Audio 3
S Audio 2
X Audio 1
W Audio 1
J Audio 1
K Audio 6
M Audio 1
T Audio 3
G Audio 1
A Audio 12
S Audio 1
L Audio 1
X Audio 5
P Audio 1
P Audio 6
G Audio 3

ASK THE COMMUNITY