Solved! Blinking power indicator compaq presario laptop

ssrimany

Distinguished
Aug 25, 2011
2
0
18,510
0
Hello,
Laptop works with AC adoptor but power LED blinking. On removal of the Power Jack, the battery condition icon shows a cross mark over the fully discharged battery. After removal of and re-installation of battery, the power LED glows (with AC adoptor connected), but after few secs, starts blinking again.

Is it a symptom for bad battery / bad power circuits / Bad Days Ahead.
 

itzdanielp

Distinguished
Aug 23, 2011
37
0
18,590
3
It is probably because the circuit that disperses power to the battery for charging has gone bad. That is why it runs properly with AC power, but the battery is getting absolutely no charge. Even if the battery was no longer holding a charge, it shouldn't be fully discharged instantly after charging.

or.... it could just be a bad battery.
 

itzdanielp

Distinguished
Aug 23, 2011
37
0
18,590
3
It is probably because the circuit that disperses power to the battery for charging has gone bad. That is why it runs properly with AC power, but the battery is getting absolutely no charge. Even if the battery was no longer holding a charge, it shouldn't be fully discharged instantly after charging.

or.... it could just be a bad battery.
 
Thread starter Similar threads Forum Replies Date
URAIBLAKHANI Laptop Tech Support 0
logorrhoeic Laptop Tech Support 3
doantientai94 Laptop Tech Support 3
MarleT Laptop Tech Support 0
A Laptop Tech Support 3
B Laptop Tech Support 0
Mahdi87 Laptop Tech Support 1
E Laptop Tech Support 2
B Laptop Tech Support 1
A Laptop Tech Support 1
A Laptop Tech Support 1
P Laptop Tech Support 3
S Laptop Tech Support 1
R Laptop Tech Support 1
D Laptop Tech Support 6
B Laptop Tech Support 1
S Laptop Tech Support 1
C Laptop Tech Support 1
A Laptop Tech Support 2
A Laptop Tech Support 1

ASK THE COMMUNITY